Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Starfleet Veteran
Join Date: Jun 2012
Posts: 326
And the problem stems from my main character. During the final leg of the mission which turns into a fire fight.

He lost the ability to fire his main weapon on single or burst mode. During a few engagements, I watched the animation of the single burst showed itself a few times, but the remaining times, it never appears, and there is no damage output witness.

The burst mode was a complete no show, on the visual. Only the physical melee weapon for combat functioned as prescribed.

And it looks that Orion males brutes are ramped up on doing more damage as well, but that may be intended in the design.

Was able finishing it, with the guilty party escaping to his shuttle *sigh*. But I am not doing any more ground combat, with that 'glitch' present as is.

And I do battle in Elite mode, as a sidenote. But the weapon lack of anime portion is very distrubing.

Task Force Zulu--Back to Duty X4 SB T1.5, Tac 2, Eng 1 & Sci 1.
To the Edge of Space and Beyond

Subscribe to STO--1200+ days
LTS December 2011

Last edited by truewarper; 11-22-2012 at 11:29 PM.
Lieutenant
Join Date: Nov 2012
Posts: 52
# 2
12-06-2012, 03:39 AM
Not only that, it is way too difficult imo!
Starfleet Veteran
Join Date: Jun 2012
Posts: 301
# 3
12-07-2012, 05:54 AM
The groups are too close and it seems that NPC are still dealing more damage than appropriate for a solo mission. I constantly saw my shields being shredded and heavy health loss after one or two blasts.

The techs say that there is no change in ground stats for NPCs, but since S7 start it has been more irritating to do ground missions since you are taking mor damage than the NPCs.
Ensign
Join Date: Jan 2013
Posts: 2
# 4
02-04-2013, 07:48 PM
Yeah this is a super tough mission. I died so man times it's almost comical. I attack one group and I see this swarm of red dots come at me. I think something is up with this mission but I'm not an elitist so maybe it's me...
Career Officer
Join Date: Jun 2012
Posts: 161
# 5
02-04-2013, 08:52 PM
Just did it (with about 10 wipes) on Advanced with my Tac officer and 4x Tac BOffs.

It's pretty much the Enforcers that are doing the insane damage. A couple times they 1-shot my whole team (in Mk XII purple armor and shields) with their Bolt Spray attack.

The resists of all the mobs also seem ridiculously high. There were a few times I did an Exploit attack on something exposed, and the health/shield bar moved like a fraction of a millimeter.

The OP's problem may be due weapon malfunctions or similar nuisance ability/CC.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:37 AM.