Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Windows 7 x64
01-11-2010, 02:54 PM
Are there any known issues with this version of windows and STO?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-11-2010, 02:55 PM
There is a gentleman we've been trying to help in the Star Trek Online discussion forum... let me dig up the link. Other people seem to have no issues with Windows 7 x64 whatsoever.

Here it is....
http://forums.startrekonline.com/showthread.php?t=55159

We suspect it was due to a corrupt client download but we have not received confirmation from OP yet.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-11-2010, 02:56 PM
None that I've come across. You should be just fine
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-11-2010, 02:58 PM
Been using Win 7 64 bit since Champions Online release. And I've had no problems at all.

If you are using an nVidia graphics card, however, Is uggest rolling back to the 190.62 drivers, otherwise you can run into stuttering issues on ground.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5 Thanks
01-11-2010, 03:00 PM
Cool, thanks guys :-)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-11-2010, 03:26 PM
Go with everything Silverspar said. I'm running Win 7 64 bit and NVidia... you'll pretty much need the 190 drivers for a smooth experience.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-11-2010, 03:32 PM
Good heads up on the Drivers. We Should start a sticky on known issues with known workarounds. this is a very handy piece of information because I played with different drivers and it sucked big time on ground missions. Or on the ground in general.


I know with a laptop with no real video card, you can go 1/2 detail and it runs pretty smooth, horrible if you keep at full detail. (provides some entertainment at work)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-11-2010, 03:30 PM
I've been hearing that people with graphic issues are ones that have been using mulitple video cards, I guess the game doesn't have good support for dual video cards. I use the latest nvidia drivers for just one 8800 GTS 640mb video card and have not had any issues graphically at all.


EDIT: I'm also using windows 7 64bit.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-11-2010, 03:41 PM
Quote:
Originally Posted by Lordcynric View Post
I've been hearing that people with graphic issues are ones that have been using mulitple video cards, I guess the game doesn't have good support for dual video cards. I use the latest nvidia drivers for just one 8800 GTS 640mb video card and have not had any issues graphically at all.


EDIT: I'm also using windows 7 64bit.
Yeah, my SLI NEVER worked right... so i upgraded a while ago to one card... screw SLI anyways for now.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-11-2010, 03:56 PM
Running Win7 Enterprise N (64). So far so good.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:43 AM.