Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
I have been stuck at the loading screen for Sol system since before the server restart last night. I have
re-logged multiple times and have waiting on that screen for as long as 30 mins.

There anyway I can get a get out of limbo push from a dev/admin?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-13-2010, 07:08 AM
Only fix is lowering video setting to minimum if that doesn't work... enjoy playing the tutorial over and over for now.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-13-2010, 07:42 AM
My suggestion would be that the loading screen let you know if you've been disconnected or if it's not actually doing anything.

Right now it'll let you wait indefinitely long after it's failed to load or connect.

On top of this, it can't be cancelled or quit. You have to control+alt+delete to close the game down and retry.

My suggestion would be to give it an optional "cancel" button that shows up if the connection drops or a period of time elapses. It could either dump you back to login, or ideally, whatever location you just came from. Either is better than being left permanently in limbo.

Also, as has been mentioned, you can't even submit a bug report from the load screen. Perhaps that could be added to make sure devs become aware of things like this?

I'll just add that my character is also permanently stuck loading sirius sector each time i log in with him, and there's currently no way to avoid or stop it. Definitiely something that needs to be urgently looked into.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:02 AM.