Ensign
Join Date: Oct 2012
Posts: 12
# 141
06-16-2013, 10:07 AM
Quote:
Originally Posted by atogorn View Post
No, it has not.
There a still a few ppl out there where the "solutions" just don't work.
I tried all solutions in this forum and NOTHING worked.
I am still missing my Legacy pack.
ty, so I'm not the only one with this issue (though it's only the rom starter pack in my case that does not show in Bundles-tab nor anywhere else).
Is there some kind of schedule when this is gonna be fixed? I don't expect it to happen overnight, but some kind of ETA would be nice.

Also had problems reporting it, writing a ticket on website seems bugged (my english isn't good enough to describe technical issues... browser is is redirected to another url, then redirected back and forth until browser simply breaks off. happens on firefox, opera and IE).
Writing (by now) 3 tickets ingame was not deigned with any kind of response in 2 weeks.
Ensign
Join Date: Sep 2012
Posts: 3
# 142
06-18-2013, 01:40 AM
Quote:
Originally Posted by antras1 View Post
ty, so I'm not the only one with this issue (though it's only the rom starter pack in my case that does not show in Bundles-tab nor anywhere else).
Is there some kind of schedule when this is gonna be fixed? I don't expect it to happen overnight, but some kind of ETA would be nice.

Also had problems reporting it, writing a ticket on website seems bugged (my english isn't good enough to describe technical issues... browser is is redirected to another url, then redirected back and forth until browser simply breaks off. happens on firefox, opera and IE).
Writing (by now) 3 tickets ingame was not deigned with any kind of response in 2 weeks.
I share your story and your pain.
My Rom Capt. is almost LvL 50 now.
Starting to ask myself if there is any reason loeft to keep the pack.
Ensign
Join Date: Oct 2012
Posts: 12
# 143
06-19-2013, 01:54 PM
Brandon,
could you please give a short statement that our problem (postings directly above) is acknowledged and your team is working on it, presumably getting it fixed until ... ?
Or at least acknowledge it SOME way.

Right now cryptic promised us a product, we paid for it, it was not delivered to us nor were we offered any compensation or information.

Thank you, it would mean a lot!
Former PWE Community Team Lead
Join Date: Jun 2012
Posts: 9,046
# 144
06-20-2013, 03:55 AM
Quote:
Originally Posted by antras1 View Post
Brandon,
could you please give a short statement that our problem (postings directly above) is acknowledged and your team is working on it, presumably getting it fixed until ... ?
Or at least acknowledge it SOME way.

Right now cryptic promised us a product, we paid for it, it was not delivered to us nor were we offered any compensation or information.

Thank you, it would mean a lot!
I just tested a purchase on a new account, and it worked. I was able to go in-game and claim it, too.

Is it possible you did not confirm your purchase? Try clicking this link (which is in the OP at the top, in lime-green text): https://billing.perfectworld.com/stolegacy/complete. What happens when you go there?

When you go here (https://my.perfectworld.com/account/sto), it should show "Legacy of Romulus Legacy Pack" under 'Activated Features'. Is it there?

EDIT: If you go through the completion step AND it's not showing under the 'Activated Features' section, the purchase may not have gone through. If you confirm that the purchase did go through with your financial institution, please reach out to our billing team at http://support.perfectworld.com ('Contact Us' tab, 'Billing' for the category drop down). If you are not able to reach the support site, please email directly to customerservice@perfectworld.com and put "billing" in the subject line and as many details in the message as possible. Filing a ticket is always the preferred method to contact us as you can ensure your ticket is in the right queue via the category dropdown.

Please note that tickets are answered in the order received, and as fast as possible.

Cheers,

Brandon =/\=
Brandon "BranFlakes" Felczer | Former Community Team Lead for Perfect World Entertainment

Last edited by pwebranflakes; 06-20-2013 at 04:04 AM.
Ensign
Join Date: Jun 2013
Posts: 2
# 145
07-07-2013, 09:10 AM
Quote:
Originally Posted by pwebranflakes View Post
I just tested a purchase on a new account, and it worked. I was able to go in-game and claim it, too.

Is it possible you did not confirm your purchase? Try clicking this link (which is in the OP at the top, in lime-green text): https://billing.perfectworld.com/stolegacy/complete. What happens when you go there?

When you go here (https://my.perfectworld.com/account/sto), it should show "Legacy of Romulus Legacy Pack" under 'Activated Features'. Is it there?

EDIT: If you go through the completion step AND it's not showing under the 'Activated Features' section, the purchase may not have gone through. If you confirm that the purchase did go through with your financial institution, please reach out to our billing team at http://support.perfectworld.com ('Contact Us' tab, 'Billing' for the category drop down). If you are not able to reach the support site, please email directly to customerservice@perfectworld.com and put "billing" in the subject line and as many details in the message as possible. Filing a ticket is always the preferred method to contact us as you can ensure your ticket is in the right queue via the category dropdown.

Please note that tickets are answered in the order received, and as fast as possible.

Cheers,

Brandon =/\=
Brandon, thank you for the reply.

I however, do see the legacy pack under my active features, but cannot access any of the items on my account. My toon is level 5 and should at least be able to grab the T'Varo Light Warbird. However, I go to the C-Store and click "legacy" all of the items appear for a brief moment and then disappear. I have no boxes in my inventory.

Edit... make sure you read the part on the first post that tells you to go to the BUNDLES area of the c-store...

Last edited by jmeyer1980; 07-07-2013 at 09:16 AM.
Lt. Commander
Join Date: Feb 2013
Posts: 103
# 146
07-13-2013, 03:13 PM
Dear mods/Cryptic,

This information may be valuable. I think there is an error in your confirmation process preventing the bundle from appearing. I first purchased the starter pack yesterday. I tried to confirm my purchase several times to no avail. It showed up as having been successfully added on my account page however. It was only the next day while logged on to my romulan character that I clicked on the confirmation link and the bundle actually appeared. To be clear, I also tried while not logged on the following day and it still did not work. So to recap, I logged on to my romulan character after having waited overnight to get the bundle to appear. I hope this information helps you resolve future issues.
Ensign
Join Date: Oct 2012
Posts: 12
# 147
07-19-2013, 06:16 PM
Took a few weeks vacation because I just needed a little break after one year of near constant STO.
Now I'm back to find your answer, Brandon: Thank you very much, it means a lot.
Also, the idea to email your support team is a great one, gonna do that immediately.

THX!
Ensign
Join Date: Apr 2014
Posts: 10
# 148
04-29-2014, 04:17 PM
[Deleted.]

Last edited by jasondswift; 04-30-2014 at 05:41 PM.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:28 PM.