Lt. Commander
Join Date: Dec 2007
Posts: 120
My 2 friends got keys from Tentonhammer. Registered them and the site took them. It says open beta under my account. When they tried to login to the launcher they get a msg saying

Account Error Contact Billing Support
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-12-2010, 08:30 PM
Server is undergoing maint atm.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-12-2010, 08:32 PM
Right thats fine, but I could login to the launcher, but they couldn't Which is why Im making this post
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-12-2010, 08:35 PM
As far as I know that's the lingo Cryptics using for server down right now. I'm getting the same error. Or actually I WAS. Now it's unable to authenticate my account to load the launcher.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-12-2010, 08:35 PM
The account server is offline for an upgrade, it will be back shortly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-12-2010, 08:46 PM
Hopefully this is the issue then.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-12-2010, 09:02 PM
and now ontop of all this the keys on my account are no longer there and i dont have my preorder key anylonger

this needs fixed asap
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-12-2010, 09:05 PM
Same issue Draul. I am sure they are fixing it and when they get done with maintenance our beta access will show up again. I made another post about it as well.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-12-2010, 09:10 PM
I hope this is the case cause all my keys even my admiral uniform one is gone from my account.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-12-2010, 09:11 PM
Check again guys mine just came back a few seconds ago.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:28 AM.