Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Bugs I've noticed
01-15-2010, 12:53 PM
Probably all have been mentioned but I don't scan through the bug message boards...

1. Some missions will have the communication pop up constantly come up in the middle of fights. Even if I've read everything they have to say it will still pop up over and over again. I eventually have to just drag it to the corner so I can finish the fight.

2. Beaming into space/ground a lot of times my body will beam into space and I have to wait till it changes to a spaceship or my spaceship beams to the ground and I have to wait till it changes into a person before I can continue.

3. It's sometimes very hard to target something by clicking on it whether it be a ship, anomaly or "objective".

4. In the tutorial I noticed that sometimes if you had a table between you and a Borg it would just walk into the table and you could have your way with it.

5. On a space/station maps when I hover my mouse over a "circle" it sometimes will show what I'm hovering over but most of the time I actually have to click it (in space) or if I'm in a station it will not tell me what the dot is that I'm hovering over even if I click it.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:51 AM.