Go Back   Star Trek Online > Feedback > C-Store, ZEN, and Promotions
Login

Closed Thread
 
Thread Tools Display Modes
Ensign
Join Date: Aug 2013
Posts: 6
# 671
11-21-2013, 01:17 PM
I had 30 days as gold back in September I think then went back to silver. I've just activated another 30 days so right now am gold again.
Last time I get my zen stipend straight away however this time I did not. Was wondering when it will arrive?

Is it the same day of the month that my first gold subsciption was activated on? I think this was the 3rd so if that is the case i'll need to wait for the beginning of December?

EDIT it came through/

Last edited by kenshinuk; 11-21-2013 at 02:49 PM.
Empire Veteran
Join Date: May 2013
Posts: 26
# 672
12-16-2013, 06:41 PM
I have been away from the game for past 3 months. I just returned to find I still have 1500 Zen (same as I had before I took a break). Why am I not receiving Zen for the past three months? Do you have to actively login to continue getting monthly zen with lifetime memberships I don't understand?
Ensign
Join Date: Jul 2013
Posts: 17
I signed up back in late October or early November and I did get the zen that first month. But I have not gotten any since then. Does support even read these postings? Do they even care?
Ensign
Join Date: Dec 2012
Posts: 2
# 674
02-01-2014, 05:29 PM
Looks like I'm in the same boat. Been away for a while and still have the same amount I had when I was last on. So much for being a lifer since beta
Republic Veteran
Join Date: Jun 2012
Posts: 7
# 675
02-02-2014, 02:58 PM
Reading this makes me think about the stipend I didn't receive during the time I was busy IRL...

June-July '12 through October '13, if memory serves.

It also makes me think about how there is no record on when our STO Zen amount changes...what a coincidence being unable to look things like that up as a player would be a disadvantage to PWE...
Career Officer
Join Date: Jun 2012
Posts: 15
# 676
02-02-2014, 10:30 PM
At least I am not alone here...I thought I was losing my mind. I wasn't sure the Stipend still happened at all. Looks like I may not have been getting it. I've been doing other things for a while...playing other games...Figured I'd let my stipend build up and when I had time to play again, I'd have built up quite a bit....But alas I do not.....Do we get screwed out of it now?

Also noticed apparently my forum isn't linked to my game account for some reason.......
Survivor of Romulus
Join Date: Jan 2013
Posts: 56
# 677 Missing Zen Stipend
03-03-2014, 04:47 PM
I have not been getting my Stipend for a few months. i have just found out that it was still going on. I would like to get it back since i am a gold member for 4 years.
What a World...Server Crash...Respawn....borg Invades ...Respawn...
Ensign
Join Date: Dec 2012
Posts: 1
# 678
03-03-2014, 04:58 PM
Oh jeez... I've been a Lifetime subscriber since day one and have never received any stipends. Just found out about those too, kinda really ticked off that I never got any...
Ensign
Join Date: Jan 2013
Posts: 17
# 679
05-06-2014, 01:52 AM
I purchased the lifetime package a year ago and never recived my promised monthly stipend....and from what I heard from others it's pointless to try to get it resolved..so I guess I'll just have to put up with this rip-off.
Lieutenant
Join Date: Sep 2012
Posts: 75
I had a couple months last year where fixing this issue basically broke my getting stipends at all and then it was resolved and I been getting them like clockwork since, on the 9th of each month, until this month, where they are clearly late again.

Am I to take it that this has been rebroken in Season 9?

UPDATE: Got my stipend a few hours after posting this, a day late from normal, but I got it.

Last edited by vizhonia; 05-10-2014 at 02:26 PM.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:14 PM.