Lt. Commander
Join Date: Dec 2007
Posts: 120
Here are my own recommended steps for resolving crashes to desktop during ground missions.

Problem:
You are in a ground mission and you get a crash to the desktop. Usually, the Cryptic Error Reporting app will pop up. This might manifest itself as the game "freezing up", but if you press Ctrl+Alt+Del, the system should respond. If your system is totally unresponsive, displaying a BSOD, or shutting off during gameplay, these instructions may not be effective.

Causes:
The reason for the crashes appears to be an interaction between the game's Direct3d code and your system's graphics drivers. Hopefully, through successive patches of STO and continuous releases of the Nvidia and ATI drivers, the issues will be resolved soon.

Applicable Hardware:

This is definitely applicable to ATI hardware. I am running a Radeon HD5970, currently the latest Radeon GPU, so the limitation is definitely not the hardware -- the limitation must be the software, i.e. the drivers or STO itself.

I have not heard confirmation that these steps might resolve issues for Nvidia users, but it is possible.

Solution/Troubleshooting Steps:

The launcher has an option called "Safe Mode". The goal is to enable Safe Mode, and then slowly step back up to decent graphics detail, without enabling the option(s) that cause the game to crash.

1. Enable "Safe Mode" in the launcher options.
2. Start STO.
3. Log out before you select a character, and go to STO's main menu's options, under the Video tab.
4. For the screen resolution type, select "Windowed Maximized". On many graphics cards, this is better than full screen for stability reasons, but it visually appears the same as full screen mode. Note that it is not the same as full screen mode, because full screen mode uses a different set of modesetting routines.
5. Make sure you enable auto-framerate stabilization in the Troubleshooting section. This will help a little in preventing lag and crashes, but is not a fool-proof solution for either.
6. Play the game for a while (at least an hour) on both space and ground missions. If it is stable and doesn't crash for you, then go back to the options menu and enable one "eye candy" feature -- be it higher detail textures or increasing the field of view or whatever.
8. Avoid these three options: anisotropic filtering, antialiasing, and bloom. Save them for last. If all the other options, when enabled, still allow you to play the game stably, you should be happy. You don't really need these three things, and they are the most likely to cause crashes.

If you notice that enabling a particular option caused a lot of framerate lag, or caused you to crash, then you have isolated the problem down to that one option, and you can then disable it and proceed along with enabling other options, as long as they don't make you crash too.


If running in safe mode without enabling any eye candy still causes you to crash, well... you might look into an upgrade of your graphics hardware, or at least a clean install of your operating system. Also, get away from XP -- I highly recommend Windows 7 as a more stable platform for this game, due to its superior graphics driver framework.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-16-2010, 02:43 AM
I'm going to have to try this when I get home today from work. I'm using a Radeon 4890, it should be more than enough to process this game's visuals, no? Ugh, I hate computers.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-16-2010, 03:10 AM
You think it's bad from the UK...., you should try from here in New Zealand....!!

If I can log in without a CTD, I can test for about 30 seconds before I get a 'Server not Responding' or massive rubber-banding... Still trying to finish the tutorial after 12 hours...!!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:36 PM.