Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Ship versus Ground Avatar Bug
01-21-2010, 08:13 PM
The biggest bug I've run into in open beta has been when my avatar has been displaced by either my ship on ground or my ground avatar in space. While there are a lot of functional bugs and fine touches that will be made over time - I see this as a MUST FIX prior to launch. I had hoped that with this latest patch (ST.0.20100119a.7) that this would have been fixed - but this has not been the case. I have noted some changes surrounding this issue though which is kind of amusing... When going into sector space and my ground avatar appears - now it "falls" to the bottom of the map and suffers about 50% physical ship damage as all of my UI seems to be correct - but my ship is a guy (or gal depending on the character). While the avatar seems to revert back to its proper identity in 5 to 30 seconds - the real problem here has been in ground combat where every time that my ship "beams down" then it is always without my BO team which makes a lot of these scenarios a little tough - because when the ship turns back into my ground avatar - no one invites my team to beam down. So the point of this thread is to get some attention to this issue and hope that it carries some weight with the developers.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-21-2010, 08:14 PM
OMG man... theres like a thousands posts with this garbage in it. It is NOT A BUG. I has to deal with latency issues. Thank you, come again.
That is all.

PS You have been added to my ignore list.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3 ya its a bug
01-21-2010, 08:36 PM
Actually it doesn't matter what the cause is.

If the user sees it as a bug its a bug. Or atleast a problem that needs to be addresed.

So either they need to hide the new zone with a loading screen for longer or work on reducing latency.

Its ok to report something as weird as a person falling through space or a giant ship going around on a planet.

This certainly needs to be addresed before launch. I can just see the video review on gamespot featuring this hilarious bug.

Just something to think about.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-21-2010, 09:02 PM
Quote:
Originally Posted by SteppenRazor
OMG man... theres like a thousands posts with this garbage in it. It is NOT A BUG. I has to deal with latency issues. Thank you, come again.
That is all.

PS You have been added to my ignore list.
Yeah... It's still a bug regardless of how it happens, and if this game is going to be as popular as I think it is, this BUG needs to be fixed. It's not acceptable to beam onto your ship only to beam in the middle of space and fall endlessly. Not too mention that when you beam down on an away mission as your ship you can't get your crew to fight with you, your basically boned. I think we testers wouldn't make so much of a fuss if the Dev's would at the very least post a sticky that this is being worked on.

I'm not sure they are or not, this is one of those grrr moments, I think they are though... but I'm not 100% sure. YOU SEE WHAT I MEAN!!! GRRR!!! lol
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-22-2010, 01:02 AM
Quote:
Originally Posted by SteppenRazor
OMG man... theres like a thousands posts with this garbage in it. It is NOT A BUG. I has to deal with latency issues. Thank you, come again.
That is all.

PS You have been added to my ignore list.
There you go OP, now that you know what causes this issue it won't affect you.

OH WAIT
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-22-2010, 01:10 AM
Quote:
Originally Posted by SteppenRazor
OMG man... theres like a thousands posts with this garbage in it. It is NOT A BUG. I has to deal with latency issues. Thank you, come again.
That is all.

PS You have been added to my ignore list.
You are completly right this is not a bug, it's a game braker. I can't count the times I have fallen so far done in space that it's taken about a minuete just to get back to where I started (and that is just since last night :S)
As this is in Beta test I can except these fundimental flaws BUT if this is still like this in release I cannot imagine many people will hang around or even pay for an account.

Cryptic have got to solve this problem before STO goes live or it will bomb
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-22-2010, 01:11 AM
Dudes, this is a MAJOR bug. Why THE HECK this one is not corrected ?

I had to play "Starbase 24" alone without my crew because of this bug ... No beam button, no ship com, nothing.

And I had to wait HOURS till the ship graphics and overall nav datas back online when going to starbase space (many times my screen is just black with my avatar on it, and nothing happens. Unable to warp out, unable to move more than 10 meters etc ...). I had to disconnect to correct this by myself.

/ignore SteppenRazor

DAMN, where is the IGNORE botton (still searching ...)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-22-2010, 01:18 AM
beamed down to the Planet and low and behold I am in starship form (ohh fun whee I am a Roomba here to clean your floor). I know you all have had that happen so I waited around for my away team to join me and they forgot to get off the ship. Crips I am stranded and alone on a hostile planet!!

So I was going to abort the mission because there was no way i was going to kill all the gorn on the planet by myself. I call for immediate transport off the Hostile planet but before the transporter operator could lock on to me and beam me up I cancelled my abort attempt.. What was I thinking ? Suicde run ? PERHAPS.

I was then invisible..Humm this is odd I am moving around ... Humm I have no away team...I am FREEKIN invisible!! cool..

So me being me I decided to see just how invisible I really was. I decide to try and shoot at some Gorn Defenders and YUP I was indeed invisible. I killed him and he NEVER even saw me!! never aggroed me Heck he was good enough to let me shoot at his flank too.. SO I decide to try the mission which was to disable 3 power towers and finally kill their leader..Humm I'm INVISIBLE!! and UNKILLABLE HOW UBER!! I'm a Superhero

AM i playing Champions Online... NO This is Star Trek

SO i proceed to kill every gorn on the planet by my bad self in Super Hero form as the " Invisible Man" with the power to not be seen or killed .. I WON.. I CHEATED...ohh its a bug.

Actually I think i may not be a bug now that i have studied this. I have determined that a Klingon was standing in the bushes and put a cloaking field around me.

I think I want to be a Klingon now !

But it surely was a fun bug!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-22-2010, 01:32 AM
Quote:
Originally Posted by SteppenRazor
OMG man... theres like a thousands posts with this garbage in it. It is NOT A BUG. I has to deal with latency issues. Thank you, come again.
That is all.

PS You have been added to my ignore list.
Honestly... this is a major bug. What does server/client latency issue have to do with displaying the wrong avatar while the client is able to display the space map and let your avatar fall to ground of the space map box
and on ground missions you see your space ship hover a few feet above floor?

The server was able to handle your "Beam me up"-"Beam me down" action ... so whats wrong with the client that it is not able to show the correct avatar?

Maybe it depends on latency issues where the client is not able to get all the data to display your customized avatar correctly. Then the client shouldnt display anything and should wait for all serverdata he needs.
And not the way it works now... "i havent got all data for your avatar.. but ill show you the space map and let your avatar fall down towards the space box bottom... and when i got all data your ship is damaged to 4%..."

IMHO: That's a bug...


Sorry for wrong grammar and whatever... english is not my 1st language
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:44 AM.