Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Unofficial Mac Version 1.4.1
01-22-2010, 12:08 PM
This Thread is now obsolete, please refer to this thread for ongoing developments


What the heck is the Unofficial Mac version?
Its a mac .app you can put the Windows version inside of, and run it on Mac OS X without having to install or use Windows! The final product looks and works like a normal Mac .app (for the most part). This download is a "wrapper" not the full game. You will have to either copy your installed version from Windows inside of it (fastest), or reinstall the game into it and do full patching and everything... More specifically, it is a Wineskin wrapper.

just a big note...

this is not made by or supported in any way by Cryptic Studios, or anyone associated with Cryptic Studios.. this is entirely fan made, by me (@doh123)... with the use of my own project called Wineskin

System Requirements are the same as Windows version, since it uses the Windows version, but it runs on Mac OS X 10.6, or 10.7 (10.5 is no longer supported)
Intel GMA950 and X3100 GPUs will not work correctly, or at all.

***Download link is at the bottom of this post in the rainbow section***

How To multitask in Fullscreen!
Use CMD+Opt+A to toggle fullscreen capturing the whole display or not.

Read the directions that come with the download to see how to properly set your resolution or window mode.

If your crashing in Earth Space Dock, you need to try lowering down some graphic settings at least temporarily... turning on half resolution usually works while at ESD.

Bajoran Fire Caves
Weird graphics bug here, that turns the screen gray. How to fix it? Set your graphics setting off of custom settings and set it down to bare minimum low settings... then you should be able to see everything. You can then turn all your graphics settings back up and it should remain fine while your there...

******************************************
Click here to download Star Trek Online Unofficial Mac Version 1.4.1 Direct download link hosted through Dropbox.com
The download comes with directions on how to use this wrapper
double click the .zip file to unzip it, it will give you a folder with the wrapper, and directions.
******************************************

Backup Download Link at Mediafire-->All STO UMV versions made are available here

Last edited by tobar26th; 10-21-2012 at 03:13 PM.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-22-2010, 12:12 PM
Clean it up a bit (read: sound) and I might be interested. Right now up unitl this patch. bootcamp STO has worked well.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-22-2010, 02:17 PM
Quote:
Originally Posted by ClingingMars View Post
Clean it up a bit (read: sound) and I might be interested. Right now up unitl this patch. bootcamp STO has worked well.
thats the plan.. but its nice if people help test things since I do not own every Mac configuration out there to test on myself... which is why I stated its just for testing, and its an alpha...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4 first run
01-22-2010, 02:52 PM
HI doh123

Thanks for this one and for your answer on the other thread.

I downloaded the link and followed your steps.
1. i must set up the exe
2. the login screen in IE is weird
3. the game started in fullscreen but the view was only on the left top corner i think 1024x768px
4. no sound
5. the font is strange i have tested crossover games the font there was ok
6. nothing at this time more while the server is down i came only to the character selection.

my mac is mac book pro 17" , 3.06GHz CPU, 8 GB RAM, MAC OS X 10.6.2
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-22-2010, 03:25 PM
Quote:
Originally Posted by Treel View Post
HI doh123

Thanks for this one and for your answer on the other thread.

I downloaded the link and followed your steps.
1. i must set up the exe
2. the login screen in IE is weird
3. the game started in fullscreen but the view was only on the left top corner i think 1024x768px
4. no sound
5. the font is strange i have tested crossover games the font there was ok
6. nothing at this time more while the server is down i came only to the character selection.

my mac is mac book pro 17" , 3.06GHz CPU, 8 GB RAM, MAC OS X 10.6.2

yes... see the thing I wrote about resolution changing. Xquartz doesn't support proper RANDR so the game tells Wine to change resolutions, and Wine tells Xquartz, and Xquartz says "huh wha?" and doesn't do anything.

Make sure your in game resolution setting is the same as the WineskinSettings.app resolution setting, and it will take up the whole screen. if you run STO in 1024x768, set WineskinSettings.app Screen options to be fullscreen 1024x768, and it'll change the resolution right when it launches... if you change it in game again later, you have to log out and change it again.... its a PITA, but its all I got right now with Xquartz limitations.

the IE screen is messed up looking i know.. but it does work.... i can get it better looking using Winegecko, but the launching button and patching doesn't work right.

I'll try the fix for sound when I can

The fonts in the log in i can fix, thats just font smoothing disabled.... its the in game fonts I'm mainly worried about that are ugly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-22-2010, 04:31 PM
Great job doh123, I'm downloading right now and will test this out sometime tonight.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-22-2010, 05:45 PM
ok.. thanks to someone else who found out the way to fix the sound bug in Wine....

I now have a version with working sound!!

it still has the graphics bug that happens in some places, that ones gonna take longer to figure out... just remember it happens the most in sector space... opening closing windows (inventory or whatever) can help.... and I know the fonts are still ugly.

I'll update the link in the main post to show all the versions I make

I need to know if there is a LONG start up time, at least the first time... apparently there might be font config issues and WIne is having to index fonts... which makes initial start up really slow.

but Alpha 2 is up, same as alpha 1 but has working sound.

oh and for a tip.. for normal fullscreen, if you want to multitask easy, the easiest way is to Hide the game with CMD+H .. then clicking on it in the dock will get it back.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-22-2010, 06:37 PM
Alright I ran into a problem. It ran the installer fine but after install when I open the Star Trek Online.app a Microsoft DirectX installer pops up. If I choose to continue it installs some .dll files and says its finished however on clicking the finish button the cursor turns into an X and the application closes, if I choose to not install I get the X cursor and the app closes.

My system specs are:
Mac Pro, 2 x 3 GHz Dual-Core Intel Xeon, OS 10.4.11, 5GB RAM, ATI X1900 XT

Edit: I'm re-installing from scratch as I think I missed a step.

Update: I got the launcher to open after install, it kept giving me IE script errors but I just selected yes to running the script and it started patching. It patched to about 200 MB and the launcher closed, when I reopen Star Trek Online.app I get the same DirectX install thing as before.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-22-2010, 07:27 PM
Quote:
Originally Posted by Viper358 View Post
Alright I ran into a problem. It ran the installer fine but after install when I open the Star Trek Online.app a Microsoft DirectX installer pops up. If I choose to continue it installs some .dll files and says its finished however on clicking the finish button the cursor turns into an X and the application closes, if I choose to not install I get the X cursor and the app closes.

My system specs are:
Mac Pro, 2 x 3 GHz Dual-Core Intel Xeon, OS 10.4.11, 5GB RAM, ATI X1900 XT

Edit: I'm re-installing from scratch as I think I missed a step.

Update: I got the launcher to open after install, it kept giving me IE script errors but I just selected yes to running the script and it started patching. It patched to about 200 MB and the launcher closed, when I reopen Star Trek Online.app I get the same DirectX install thing as before.
X1600s and X1900s are known WIne graphics issues.. so don't expect too much...

I have never seen it prompt for DirectX... if it does, you do NOT want to install it, even if it works, Wine will run faster using its own directx files, and not MSes.

Answering yes to the script errors is needed... I forgot about that...

I also noticed a bug when i tried to do a full install from scratch, that occasionally the patcher would disconnect and close... it was odd... but when starting again i never had DirectX pop ups.

If you had it install any DirectX files, you need to start over again with a clean version of the wrapper... do not let it install anything DirectX related if it prompts.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10 Wow.
01-22-2010, 07:48 PM
You are to be commended. This really works very very well. I was impressed.

I have a new Macbook Pro unibody, and everything works. I even tweaked it to allow sound.

I'm a huge world of ******** player. To say that I was disappointed in Cryptic's lame managerial decision to exclude Macs is an understatement.

My name is John, and for several years I worked at Zimbra and then Yahoo.. so I understand technology pretty well. I also know what reasons are real, and which ones are dumb excuses that hold no water when investigated.

For several years, we didn't support CentOS officially because of various (stupid) reasons solely made by managers.

Cryptic's exclusion of the Mac community is disappointing. I hate when companies just don't get it...and they don't. They just don't get it. And that will probably cost them dearly.

You have single handedly given me hope that perhaps this will work.

If Cryptic's offices are anything like the rest of the world, most employees are probably awesome and really are mac fans. It's the managers that don't get it.

As far as issues, I had only one: The ghosting issue while in space. Otherwise, it performed WAY better than VMWare fusion (which ironically now owns Zimbra).

Controls, sound, video, speed were all very acceptable.

Great work!!

john h
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:50 AM.