Lt. Commander
Join Date: Dec 2007
Posts: 120
# 111
01-25-2010, 02:49 PM
Quote:
Originally Posted by motte
Hi again!
I'm running 10.6.2.
I think the Wine log is hardly of any use, it just displays loads of D3D errors (from the last fullscreen run i suppose) and its about 44MiB in size
thats a working X11 log... so something is going on before its even trying to launch the X server.


to run the game, instead of double clicking the .app... go inside Contents/MacOS folder and run the 'Wineskin' program with terminal.app.... it will say some things about what its currently doing.... and I'll know what section it was in when it got stuck.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 112
01-25-2010, 02:51 PM
Quote:
Originally Posted by liptonhex View Post
Hi again,
I downloaded your app and tried it with STO and CO
I don't expect it to work with CO... but just thought it might...

the problem with Steam is.. I have no clue how steam works, I have never used it in any way shape or form... I know that its possible to play a lot of games in Wine through steam, so there has to be a way to get it to work... but I do not have the steam version to play with. I can look into it some more.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 113
01-25-2010, 03:01 PM
You don't need to work it out.
I just figured out that when you are connected on the CO official site you can download COclient, so I guess STO client will be downloadable as well upon release. So the steam question won't be an issue, since people with accounts can get standard client for free.

This is simplier no?

Edit: Update is finished so I began playtesting it.

My config:
Mac OS X 10.5.8
2.93 GHZ Intel Core Duo
4 G 1067 MHz DDR3
ATI RADEON HD 4850

First thing everything runs smoothly (even the blue trace of the ship) BUT i'm very limitated in graphics, i've put everything I could on max and the game absolutely not the same than on bootcamp, there is no reflection at all (othing is shiny), textures are really rough.
It told me at the beginning that it wasn't recognizing my video card, am I doomed with the no mac-native-ati-driver-update-since-2007?

If there is a printscreen option i can show you the video settings and the results on screen.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 114
01-25-2010, 03:33 PM
First off doh123 Thank you!
by far this is the easiest implementation of wine i have ever used


and 2nd Steam by default has the exact same files as the normal Star trek online beta. normally this files are located at "C:\Program Files\Steam\Steamapps\Common\star trek online\" copying this directory into the .app and pointing the launcher at the star trek online.exe in this folder works fine
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 115
01-25-2010, 03:36 PM
Yeah but when you launch a steam game steam is launched as well, won't that get to any problem?
Thank you by the way. I wasn't able to find the game files in steam...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 116
01-25-2010, 03:40 PM
Quote:
Originally Posted by liptonhex View Post
Yeah but when you launch a steam game steam is launched as well, won't that get to any problem?
no actualy if you want to test it while in windows close steam and browse to the folder that holds it and launch it by it self ( i made separate icon to launch it this way so i don't get the overlay by hitting shift tab )

i did the same thing with Champions online and there are no ill effects ( aka patching and launching in steam doesn't cause it to re patch or freak out in any way )
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 117
01-26-2010, 06:55 AM
SO I dont get the steam thing....

is it just that the steam client needs to be installed in the app as well?

someone can try using the Installer inside of WineskinSettings.app to install whatever Steam has?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 118
01-26-2010, 07:04 AM
Quote:
to run the game, instead of double clicking the .app... go inside Contents/MacOS folder and run the 'Wineskin' program with terminal.app.... it will say some things about what its currently doing.... and I'll know what section it was in when it got stuck
Alright, I suppose it was a Mac OS/dock issue, because after having changed settings, it didn't start in either mode. And when I pulled the icon off the dock and started from inside the Apps folder it works again As if I couldn't have figured it earlier
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 119
01-26-2010, 07:29 AM
Almost every mac out there dual boots os x and win xp/vista/7.. so why even bother trying to emulate this in OSX? The performance will just be degraded. Just boot into win to play the game, and when done boot back into OS X.

I used to have mac, but I have PCs now.. and my PCs boot both Win 7 and the latest OS X. Aside from the bios, macs and pcs are pretty much identicle now a days in HW. Just depends which OS you want to run
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 120
01-26-2010, 07:51 AM
Quote:
Originally Posted by TallBear
Almost every mac out there dual boots os x and win xp/vista/7.. so why even bother trying to emulate this in OSX? The performance will just be degraded. Just boot into win to play the game, and when done boot back into OS X.

I used to have mac, but I have PCs now.. and my PCs boot both Win 7 and the latest OS X. Aside from the bios, macs and pcs are pretty much identicle now a days in HW. Just depends which OS you want to run
so I'm supposed to give up all my programs and software and just turn my machine into a Windows PC and have to use Windows? thats horrible.... i'd just as soon not play it at all.... why have to lose my whole computer to play 1 game, when I can run the game 90% just as good and not lose my whole computer?

I'm sure a Windows lover wouldn't ever understand it... just accept not everyone has the same wants and likes.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:09 AM.