Lt. Commander
Join Date: Dec 2007
Posts: 120
# 21
01-29-2010, 06:21 PM
Quote:
Originally Posted by Pyros View Post
It only started when they made the assignment area in the first place. They -always- appeared in your inventory.
Nah.

This is a general bug impacting quest reward items, be it a BOff or an item.

I just finished the Risa Patrol, for example, picked the engineering kit, never got it.

It isn't Azura mission specific or anything else. Just a random, probably lag caused, you don't get your item/boff quest reward bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 22
01-29-2010, 06:41 PM
Yeah I had it happen on an item (Blue personal shield from Briar patch mission) during Beta too.

Like I said, I talked with Rehpic about it in IRC today and I think they're working on it. Seems to be one of those "Only happens during stressful times" bugs that are hard to nab.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 23
01-29-2010, 06:43 PM
not getting mine either
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 24
01-29-2010, 06:44 PM
Typical Cryptic not fixing bugs again.

You think they would've learned from Champions.

Cryptic is the new Funcom.

I've never seen an MMO developer with as much bad press as Cryptic has right now. Shameful.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 25
01-29-2010, 07:28 PM
Quote:
Originally Posted by StormShade
ZippyZ gets +1 to Awesome for that post.

Thanks,

Stormshade
Actually it was -1 "Awesome" because the person didn't bother to read any of the posts stating that the missing BO's WERE NOT IN THE ASSIGNMENTS queue and apparently neither did you.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 26
01-29-2010, 07:29 PM
Quote:
Originally Posted by ZippyZ
Then I suggest you bug it, cause you should definitely have it.
This has been bugged ad infinitum since closed beta.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 27
01-29-2010, 07:35 PM
Quote:
Originally Posted by StormShade
ZippyZ gets +1 to Awesome for that post.

Thanks,

Stormshade
I wish you had read the thread more carefully. And ZippyZ gets -2 for not doing so either.

This is not a "we don't understand how to assign bridge officers" problem. This is a problem where bridge officers which are given as mission rewards are never actually given to the player. The Azura mission and the tutorial missions are examples of instances where this bug can occur.

It happens randomly, sometimes the bridge officers are awarded to the player just fine and sometimes they aren't. When it does happen you are more or less screwed out of that particular bridge officer mission reward because, at that point, the mission has completed and you don't have the option of abandoning it and trying again. Most of us who run into this problem end up deleting our characters and trying again - that was fine for beta but it's not fine for live.

This was reported in beta. Several times. And several times someone hopped into the thread and incorrectly linked completely useless information like ZippyZ just did despite being given detailed reports of the problem which clearly mention this isn't a case of not understanding how to assign BO's. Sometimes I think people don't bother reading past the title before hitting that reply button.

Please fix this bug. I personally filed a bug report about it during the beta and up to the very last day of beta I checked the ticket to see if there was ever a response given. But from what I could see it was never even looked at.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 28
01-29-2010, 07:41 PM
Quote:
Originally Posted by Combadge
This is not a "we don't understand how to assign bridge officers" problem. This is a problem where bridge officers which are given as mission rewards are never actually given to the player. The Azura mission and the tutorial missions are examples of instances where this bug can occur.
And again, I'll stress that this is a general quest reward issue, not BOff specific. Items are impacted by it as well.

So, basically, failure to get the item and/or BOff can happen with any quest.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 29
01-29-2010, 08:20 PM
I just did the level 6 officer 'quest' and it did not give me the officer. Any way to 'claim' them?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 30
01-29-2010, 08:20 PM
Just to throw my hat in the ring, I also didn't get my kit from the patrol quest, nore did I get my BOff from the Bridge Officer requisitions half-quest.

I wouldn't mind, but I really wanted that Photon Grenade II kit
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:44 AM.