Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Out of date video drivers?
01-16-2010, 06:59 AM
I've got an ATI HD4680 and STO keeps telling me I've got out of date drivers. I even went so far as to reinstall them from ATI's website and I still get the error.

Not game breaking, but certainly annoying. I played 8 hours last night with no video issues.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-16-2010, 02:15 PM
Bump for visibility ^
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-16-2010, 05:02 PM
Bump for visibility ^
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-16-2010, 06:55 PM
I have the same problem with my ATI card.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-16-2010, 07:00 PM
same here, i have same issue in champions. I have cross fire enable 4850 HD ATI Radeon tho. I hope crptic does something about this. I even went as far to update on alienwares and ati's website both times changed nothing. and when went my device manager it tells me there update but STO has a different say in it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-16-2010, 07:15 PM
what operating system are you guys running.

i have, on other games in the past, gotten an "out of date" driver issue when my version of DirectX9 was off or needed reinstalling. so you might check that you have the most current version of DX9 from microsoft, to be safe.

I am running an ATI 4670 with no problems.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-19-2010, 04:24 PM
Quote:
Originally Posted by Shotmagnet
what operating system are you guys running.

i have, on other games in the past, gotten an "out of date" driver issue when my version of DirectX9 was off or needed reinstalling. so you might check that you have the most current version of DX9 from microsoft, to be safe.

I am running an ATI 4670 with no problems.
XP x64 SP3 and I do have the latest version of DirectX.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-28-2010, 05:24 PM
I have an ATI Mobility FireGL v5700 video card. I used an online testing site that used STO's minimums and it reported I could run the game. I just installed the game today and ran it. Once I logged into the launch tool it told me to update the video driver. I could see the game graphics as it was trying to log into a server even tho the servers were down today. I went ahead and updated the driver and now after I login at the launch window it crashes shortly after that. I checked the Directx9 and it's current. I'm going to rollback the video driver and will see if I can play the game tomorrow. Meanwhile, if anyone has advice/input please reply.

trob
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9 out of date drivers
01-30-2010, 09:43 AM
I get the out of date message and my PC says I have the most up to date drivers. My PC has two interconnected ATI 4800 HDs and the game seems to play just fine even with a lot of the video settings set to max.

STO tech support said to see these forums for help. Guess I'll just ignore the message for now.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:38 AM.