Lt. Commander
Join Date: Dec 2007
Posts: 120
im trying to play sto and when i load up screen it tells my video card drivers do work i have gone to the card website and downloaded drivers and loaded them and still dont work please help thanks
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-30-2010, 07:25 PM
Quote:
Originally Posted by spaceangel72
im trying to play sto and when i load up screen it tells my video card drivers do work i have gone to the card website and downloaded drivers and loaded them and still dont work please help thanks
You need to tell us your configuration, driver release versions, etc
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-30-2010, 07:30 PM
my video card is a nvidia GEforce 6150 nForce 430
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-30-2010, 07:33 PM
That is quite a bit below the specs required but can you give all your pc details including if you are on XP or Vista etc and also where in the world you are.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-30-2010, 07:34 PM
the latest driver was installed on 11th of jan 2010 the version is 6.14.119621
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-30-2010, 07:39 PM
Tbh I think your card does not have the shaders etc required to run this game,I am pretty tired right now or would search for you,though I am about 99% sure your card is to old to run a game of this type.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-30-2010, 07:53 PM
Quote:
Originally Posted by Sinhealer
That is quite a bit below the specs required but can you give all your pc details including if you are on XP or Vista etc and also where in the world you are.
why do u want my pc details ?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-30-2010, 08:02 PM
Quote:
Originally Posted by spaceangel72
why do u want my pc details ?
umm maybe cause thats the first step in troubleshooting???
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
01-30-2010, 08:03 PM
I was going to search for the latest driver just to make sure you were up to date but you later posted the driver you were using.

Sorry mate but I really think the card you are using can not run this game in any shape or form.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
01-30-2010, 08:05 PM
Quote:
Originally Posted by Rekhan
We just updated the FAQ, but wanted to call it out here, as well. Star Trek Online's system requirements are as follows:
System Requirements
OS: Windows XP SP2 / Windows Vista / Windows 7 (32 or 64-bit) CPU: Intel Core 2 Duo 1.8 Ghz or AMD Athlon X2 3800+ Memory: 1GB RAM Video: NVIDIA GeForce 7950 / ATI Radeon X1800 / Intel HD Graphics Sound: DirectX 9.0c Compatible Soundcard DirectX: Version 9.0c or Higher HDD: 8GB Free Disk Space Network: Internet Broadband Connection Required Disc: 6X DVD-ROM Recommended System Configuration
OS: Windows XP SP2 / Windows Vista / Windows 7 (32 or 64-bit) CPU: Intel E8400 Core 2 Duo or AMD Athlon X2 5600+ Memory: 2GB RAM+ Video: NVIDIA GeForce 8800 / ATI Radeon HD 3850+ Sound: DirectX 9.0c Compatible Soundcard DirectX: Version 9.0c or Higher HDD: 8GB Free Disk Space Network: Internet Broadband Connection Required Disc: 6X DVD-ROM

Link to the news article.
your geforce is below minimum need 7950 or higher
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:29 AM.