Go Back   Star Trek Online > Information and Discussion > Star Trek Online General Discussion
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
01-31-2010, 12:42 PM
Quote:
Originally Posted by crpngdth View Post
ive been in the Q for almost 20 minutes now, went from 273 to 249 and it hasnt budged from 249 in 10 of those minutes. i dont mind Q's that much but 2-3 hr wait is not acceptable for any game. it appears that cryptics ploy of allowing pre-orders to be continued to be purchased over the weekend worked, as i think alot of people who were borderline on this game broke down and bought it the past 2 days and thus this mad influx of people at a "peak" playtime.

haha so it looks like i only had to wait 20 minutes as when i finsihed typing my other post, i checked back and was logged in. nowhere near as bad as it seemed.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
01-31-2010, 12:43 PM
Quote:
Originally Posted by Talamakara View Post
Good think I bought the extra cheese , we're gonna need it for this whiner.
And what do you trolls eat?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
01-31-2010, 12:43 PM
Yeah mines not budging either.

This game is clearly not ready for release yet.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
01-31-2010, 12:43 PM
Quote:
Originally Posted by skylatron
Isn't high interest....a good thing?

You also don't pay the monthly fee until March.
He *did* pay a monthly dude, it's included in the purchase price.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
01-31-2010, 12:44 PM
Quote:
Originally Posted by crpngdth View Post
haha so it looks like i only had to wait 20 minutes as when i finsihed typing my other post, i checked back and was logged in. nowhere near as bad as it seemed.
Well, 20 minutes for you being 200 in line? Considering I'm now #1244 or something, maybe I can play in two hours!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16
01-31-2010, 12:45 PM
fail.


0000 1010
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
01-31-2010, 12:46 PM
Quote:
Originally Posted by Hand_of_Fate View Post
What is this fracking nonsense?

You have everyone on one game server, the game isn't even released yet to have that high a population yet, and we've got queue's almost a 1000 people long?

What exactly is it I'm paying for at this point?
And you think it would be seriously any different if there where multiple servers? No, they'd all just be full.

Them being clustered into one single "server" makes no difference. There's just simply to many people for the number they current have. Hence why they need to install more.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
01-31-2010, 12:47 PM
it just kicked me out after they did the last overhaul of the surver i'm JUST LOVING THIS Crap this really blows and i have paid for this game and i'm buying it i'd expect better work then this crap the beta is over some of these problems should be fixed by now like the constant disconnects and super lag it worked fine on friday then died on saturday and still won't work for me today I'm a really into star trek but if this keeps up I'm walkin away I really don't want to do that so somebody fix this please!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
01-31-2010, 12:50 PM
Cryptic really dropped the failball on this one...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 20
01-31-2010, 12:52 PM
okay we have a ridiculous number of posts whining because the game doesn't have a Queue. So the Devs put a Queue in and not we have a ridiculous number of posts whining because they put one in. You whiners just can't be pleased no matter what the Devs do for you.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:50 PM.