Lt. Commander
Join Date: Dec 2007
Posts: 120
I did a search on the Forums to see if this is an issues and could find little information. I got a 12 sub with the two additional character Slots and i did not get the additional slots, but i do see that it was credited to me on my account. Anyone have any info on this???

Thanks
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-31-2010, 07:45 PM
Quote:
Originally Posted by noncube View Post
I did a search on the Forums to see if this is an issues and could find little information. I got a 12 sub with the two additional character Slots and i did not get the additional slots, but i do see that it was credited to me on my account. Anyone have any info on this???

Thanks
Weird. When you hover over the "create a character" button, how many slots does it say you have total, and how many characters do you have made right now?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-31-2010, 08:04 PM
The same thing is happening to me. I got a pre-order and 12-month sub, but only have two character slots available. This happened to my husband Friday, but later the slots showed up. Guess I'll wait and see tomorrow moring before contacting support.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-31-2010, 08:35 PM
thanks for the info, and i currenty have one guy with two open slotts
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-31-2010, 08:45 PM
Same here: got DAS, no +2 slots.

I can understand why the Deluxe perks don't work: no code put in yet, but the DAS bonuses should be working, seeing how Cryptic already took my money for it.


On a sidenote, my credit card statement shows I am paying for "Champions Online", not "StarTrek Online", which is weird (they forgot to fix that for STO). I never played CO.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-01-2010, 08:21 AM
Day two for me, and the two slots for the 12-month pre-order are still missing.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-01-2010, 09:24 AM
I still have not gotten my slots so i sent in a support ticket to billing, i will update post with how that works out
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-01-2010, 10:59 AM
Looks like the 12-month product is misconfigured on the servers. We will get this sorted out shortly, thanks for the report guys!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-01-2010, 11:05 AM
I'll throw a 'Me too' in there for luck.

Thanks
M.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
02-01-2010, 08:35 PM
I have gotten my extra slots, thanks
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:16 AM.