Go Back   Star Trek Online > Information and Discussion > The Academy
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
02-02-2010, 11:59 AM
I did everything listed but when I 'confirm activation' of STO Digital Deluxe, I get a message saying there was an error processing my request.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
02-02-2010, 12:04 PM
I think the retail keys are going out in batches. I just received my email and validated the key. My species are at the C store, but my 500 cash hasn't show up yet....maybe later.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
02-02-2010, 12:31 PM
Ok I got my subscription active but in the C-store I got a 4-5 items, but neither include the uniforms or the borg. Did I get the wrong extras?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
02-02-2010, 12:32 PM
Thanks Jnoh,

That worked for me!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
02-02-2010, 12:53 PM
Quote:
Originally Posted by Bot-Holliday
Ok I got my subscription active but in the C-store I got a 4-5 items, but neither include the uniforms or the borg. Did I get the wrong extras?
Ok it turns out, the things I got are part of the package...just missing the uniforms, the borg officer, Joined Trill. Do those come later or do I need to look somewhere else.

Thanks! Sorry for so many posts. Just trying to figure this out.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:49 AM.