Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Missing Special Items?
02-02-2010, 07:51 PM
I added the retail game today. I waited a long time for the patches. But I didn't mind until I noticed my special items were not in the C-Store. So I decided to log off and log back on and the patch is starting all over again. It might be a new one, but I am all out of answers. Anyone having the same issue or maybe someone knows whats going on?

Thanks
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-02-2010, 08:25 PM
Okay, a few questions... (I'm not trying to be mean or make you sound stupid, but a LOT of people just don't know what they are doing.)

1. Are you sure you put in your retail key and not your pre-order key? (Did you get a message saying that your key was sucessful?)

2. Did you check the Special Unlocks tab in the C-Store?

3. Are you sure you were logged in to your account (and not someone else's)?

I hope this solves your problem
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3 Yes
02-02-2010, 08:45 PM
All went well, it took awile for patch, but only special characters. I put in new key and checked C-Store. Thats why it doesn't make sense. Now this patch is taking way longer. Just weird
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4 I think I figured it out....
02-02-2010, 09:03 PM
For those who have the same question. If I don't post again, it means I was right. This patch is longer because the patch is loading completely. I think that the patch was still going in the background and allowed me to play for convenience. So the special items weren't placed yet. When I tried to log back in the second time I got a message that said to wait because it was updating launch. So that might be it. :p
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-02-2010, 09:17 PM
Quote:
Originally Posted by Kortez View Post
I added the retail game today. I waited a long time for the patches. But I didn't mind until I noticed my special items were not in the C-Store. So I decided to log off and log back on and the patch is starting all over again. It might be a new one, but I am all out of answers. Anyone having the same issue or maybe someone knows whats going on?

Thanks
Where did you pre order from? I don't think all of them are in the C-Store.

Uniforms are at the tailor. (Star Base 01 around 10 oclock if the map was a clock.)

I believe the ship, is in one of the shipyard NPC's either Select Your Ship, or Customize... but I could be wrong, I couldn't get clear information when I logged in at lunch time today.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:42 AM.