Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 pre order from atari`
02-03-2010, 10:30 AM
Hey i know this mught sound like a repeat. I put out a ticket and have done everything that people have suggested. I bought my pre order from atari and have not recieved any thing . I check the c- sotre and made sure that both keys were tied to my account. I also opened a ticket. This has been very fusterating would like to know about how long will take to fix. Or if someone could look in to it....
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-03-2010, 10:44 AM
Quote:
Originally Posted by chucko2010 View Post
Hey i know this mught sound like a repeat. I put out a ticket and have done everything that people have suggested. I bought my pre order from atari and have not recieved any thing . I check the c- sotre and made sure that both keys were tied to my account. I also opened a ticket. This has been very fusterating would like to know about how long will take to fix. Or if someone could look in to it....
I have same problem although i did not buy from Atari, i got the game and the serial key, but key is not working when i try to register at server. now the ticked system doenst work for some reason, so i cant even get in contact with STO support.??
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:35 PM.