Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Extremely Confused
02-03-2010, 04:20 PM
I am extremely confused. Apparently I am still able to log into STO after the headstart. I tried adding my retail code, and on my account it says Subscription, then under it, it just has a dot. I tried adding a subscription with my retail code, as it is required, I guess, but I couldn't get my debit card to work. As far as I know, I shouldn't be able to log in. UNLESS, it added my retail code, but didn't give me a subscription. I considered that, and checked the C-Store in game, none of my Collector's Edition items, such as my uniforms, and my pre-order bonus, my Constitution-Class ship, were there. So I'm extremely confused as to what is happening. If I could get a dev to help, that'd be great, but frankly, I'm willing to accept any help at the moment.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-03-2010, 04:26 PM
Noone knows what is going on?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-03-2010, 04:32 PM
There is a grace period up till the 6th, this will let anyone with a preorder code into the game up till the 6th. They do this to give everyone a few extra days for their retail boxes to get shipped, so they're not locked out of the game till it arrives.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-03-2010, 04:37 PM
Ah, I see. Thanks very much!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:12 PM.