Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
I have a pre-order from Direct2Drive and Amazon, and have all my keys in etc.. I've claimed all the goodies on my character through the C-store, and applied the ones that required I click on them. Thats when the problem started...

After zoning away from the main star base (where I was when I claimed everything) into sector space:

- NX no longer displays on my hull, but ship screen shows properly. Only option to try and get it back requires I pay 1500 to set back to NCC, and another 1500 back to NX. I'm not paying to make up for their game mistakes..

- Pre order turret gone after equipped / zoned and activation key placed into my 2nd hotbar. The hotbar also reset all the skills the way I had the layout before adding.

- Pre order red matter capacitor gone after equipped / zoned and activation key placed into my 2nd hotbar. The hotbar reset (same as turret above)

I have tried to retrieve the items from the c-store, but am met with "you can't have it more then once per character" which is fine, but I don't have them accessible...

I've placed a ticket, but much like all my beta and live tickets they are unanswered. I've tried mousing over each slot on my ship and inventory, right click each slot and dragging things into all the slots with no luck.

I'm very concerned that I'll be defending the galaxy and my borg bridge officer will get beamed off my ship, or worse my borg captain... And I can't even get Cryptic to give me a "we have read your issue and are reviewing"

No issues with my trill or anything else that I have read about... Del Taco ship is there no problem.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-03-2010, 04:59 PM
Hmm...

No replies, so I'm guessing I'm the only person that actually got a pre-order item, then had it vanish when they zoned?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-03-2010, 06:13 PM
Last and final bump - I'm really concerned that I seem to have an issue that none of the million other players have enountered... This doesn't help my ticket status especially since a GM won't talk to me...
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:29 PM.