Prev Previous Post   Next Post Next
Lt. Commander
Join Date: Dec 2007
Posts: 120
I noticed yesterday that almost all of my items (MK V-VII) show very low stats on them.
For example:
My MK VII shields have something around 1688 hp and a regen rate of around 60. When mounted I shows 3700 hp in the char stat window but my shields still go down after one high yield III by a NPC battle ship dealing around 3-4x 300-400 damage. And this is not a simple "oh Im getting owned there must be something wrong on the other side of the screen". Just want to know where the problem lies if there is one. Might just my imagination giving me a run for my money. And it might be interesting to know that the items show normal values to other people when I post them into the chat.

On another note Id like to know if it is normal that my phaser dual cannons MK VII only deal around 50-60 damage on enemy shields using rapid fire III attack pattern alpha III, beta II and fire on my mark (I presume that the resist debuff only applies on hull damage). But 50-60 barely scratches enemy shields even with rapid fire III. This is especially curious when I see that Im getting hit by disruptor and phaser arrays for the same amount of damage (50-60).
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:18 PM.