Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 what the hell!
02-09-2010, 02:46 PM
... is wrong with this game, no1 selling game in the uk and ive been waiting months and now i find that my ship pr character keeps jittering around the screen, i wont to love this game but cannot even play, day 3 and still not of the tutorial...

anyone with similar problems...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-09-2010, 02:52 PM
It's because there are too many people running the gates. Cryptic had never dreamt about getting so many people play the game. Learning lesson. Maybe they relied on Atari's marketing protocols and prognosis and now ended up in a critical overload. haha. Next month conditions should become much better. Beta ran very smooth so by watching all those complains coming in my decision to wait until march at least was a good one.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-09-2010, 02:59 PM
*sighs* i wont to play, people must be having some kind of success, although the forums suggest otherwise...

got to admit in the morning uk time or early evening it seemed to be playing smoothly, as son as the US come online to play it goes pear shaped...

disappointed and demoralised.... *looks around for hope or some 'cryptic' reference to a solution'
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:31 PM.