Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Weapon Cooldown Possible bug
02-18-2010, 11:39 AM
So I noticed during the borg DSE that my weapons were getting locked out with a long cool down. At first I thought this was possibly a borg power, but then I noticed something particular about it as it was happening often enough to be annoying.

Essentially what happens is your weapons go into a 20 second cool down mode just like when you use a BO power. The reason why I started to think this was a bug vs a borg power is that normally when trying to re-activate a BO power on cool down does not reset the cool down i.e. I used EPtS and it's 5 seconds away from coming off cool down and I press the button again it will not refresh the cool down to the full 20 seconds again you just have to continue waiting the remaining 5 seconds. Where as when your weapons are locked down by this you have to wait the full 20 seconds on ANY weapon otherwise it refreshes the cool down back to 20 seconds on ALL weapons i.e. you have all weapons off cool down except for 1 weapon and it's at 5 or so seconds and you hit the space bar (Fire all Phasers!), no weapons fire and ALL weapons go on a 20 second cool down timer.

Has anyone else been hit by this? Or is it just me?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-18-2010, 11:51 AM
same to me if i use BO power torpedo spread I... ill get a 30s cooldown without beeing able to fire one my torps until it runs out.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:46 AM.