Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Starship Shield Issue?!
02-18-2010, 02:41 PM
*THIS IS THE TICKET I JUST SENT - IF YOU HAVE ANY INFO THAT MIGHT HELP, FEEL FREE TO RESPOND*

Greetings dear GM,

I was wondering if u could check if there's something wrong with my starship shields.
I dont mean the item itself, but the amount of shields it provides me with..

Im a Engineer ,lvl 9 Commander, on a Heavy Escort Ship..

E.g.
When I scroll over my Ship's shields it says:
2234 max shield capa (10% bleedthrough) , and 41 regen p/6s ..
This is at lvl Commander 9

While, when my fleet members (higher and lower lvled that me) it says:
7105 max shield capa (10% bleedthrough), and 129 regen p/6s ..
This is at lvl Commander 5

7776 max shield capa (10% bleedthrough), and 141 regen p/6s ..
This is at lvl Captain 7

-Remind you, all info is about the SAME shield- which I linked through the chat.

The same goes visa versa,
THEIR shields give them more shield capacity and regen, then me at a higher lvl.
Any mk iii shield is better then my mk vi shield !

I have made sure i have all the nessesary skills (for shield stuff) maxed out for my lvl, which is Commander 9.
Also are all of my bridge-officers promoted max, and max skilled (again, for shield stuff anyway)

Is there something i missed?
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:25 PM.