Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 BO's and Equipment question
02-20-2010, 09:59 AM
Are the BO's able to use Admiral Equipment or just "their" rank Equipment?

Sorry for the Noob Question.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-20-2010, 12:12 PM
They usually can equip and use the same Equipment as you. Some Items cant be equipped on BO's, not sure about the Reason.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-20-2010, 12:20 PM
They can indeed - there is a minor issue with the Admiral armour you can buy with 5th order exploration merits at Earth Spacedock however, in that it doesn't show up properly on the character model. The same thing happens with your own character if they're using one of the very rare armours from Battle Group Omega.

I've also noticed the combadge and rank pips now disappear when wearing armour, but they used to show normally on it.

As Gouv said, there is the odd item that doesn't stick to them, but there's no obvious reason for why.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-20-2010, 12:31 PM
None of the items from Battle Group Omega (gear for end-game) can be worn on your away team, at least not for me.
I can only use the items on myself, and as mentioned, the armor is bugged.

Regular admiral gear is fine, it just seems to be the Mark of exploration items.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-20-2010, 03:23 PM
Thanks for the Answers all:-)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:47 PM.