Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 In-game mail problems today?
02-21-2010, 10:23 AM
I know it's Sunday and all, people are probably crowding and straining the servers more and more. I started a new character and I sent some Rare and Very Rare BO's to myself. The first two mails arrived as normal, the third just vanished. I have checked all the other characters I have even though I just sent it to all of mine. And yes, the mail sent as normal with no timeout error.

Anyone else having this issue today, or have had it before? Wonder if they'll magically turn up at some point. Been over 20 minutes so far.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-21-2010, 02:21 PM
this happened to me few days ago. I sold stuff on Exchange (I know coz i got money and they were gone) but never got the mail that tells you but then the next day i sold something else and did get mail. Im sorry to say but it never turned up, you have probably lost your stuff.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-21-2010, 03:45 PM
It was a mail to myself, not involving the Exchange though. Actually something strange happened. After a few hours I got a system e-mail that said something along the lines that the auction items had been recovered and mail lost, and that the items were now returned. Auction? I've never seen an auction in-game though. But, the items returned to me at the end. Almost lost four purple BO's there, so I was happy to have them returned
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:13 PM.