Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
I've got the supplies needed for several relief missions but when I go back the the sector I got them from the from the "Continue Mission" button appears for a brief second after loading but then immediately disappears.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-05-2010, 10:51 PM
Quote:
Originally Posted by Trekker88 View Post
I've got the supplies needed for several relief missions but when I go back the the sector I got them from the from the "Continue Mission" button appears for a brief second after loading but then immediately disappears.
Can't help ya on that one other than to say to skip the Aid the Planet missions. Not worth the time involved when you can simply leave the system and pick a new unexplored system.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-05-2010, 11:09 PM
Maybe so, but its still a bug that needs to be fixed. I save them up, collect 3 or so, get the stuff before I log out and turn them in the next day, that's a few hundred skill points right there. And I've found that if I skip them I'll get Aid Planet back to back to back until I do accept them. Some ppl do like to help people and not always just pewpew them to death.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:47 AM.