Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
During my initial gameplay I searched the Bridge officer requisitions to find a Klingon Science officer. I found a female version I decided to purchase her as part of my crew.

I purchased the officer which still showed her as Klingon but upon activation it turned into an "unknown species" science officer.

In this bug she still has the same skills/traits the klingon officer had (honorable and warrior) but it is NOT a Klingon officer.


I am not sure if the package bugs upon activation but I wanted to post my experience for reference.

If anyone else has a similiar issue, please post it here...and if you have the merit please purchase your own klingon officers (or other races) to see if the bug continues.

Thanks
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-12-2010, 05:58 PM
I'm having a similar issue on Federation side, the bridge officer reward I get from the tutorial is always the same Unknown most similar to female officer. She always looks the same and it happens regardless of what the tooltip says I'm getting. Annoying little bug, I would have much rather have had the human and Vulcan it said I was getting.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-12-2010, 06:07 PM
Same issue, Klingon Female shows as Unknown species. Always the same one, too. Denobulan Ears, purple skin. Tried twice now.

*Federation side
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-12-2010, 06:14 PM
As a note, my bug is on the federation side.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-12-2010, 07:02 PM
Hopefully they're patching it now. Probably not, though. The "Map is Full" bug is most likely taking priority.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-12-2010, 07:05 PM
Quote:
Originally Posted by Vishmaw View Post
I'm having a similar issue on Federation side, the bridge officer reward I get from the tutorial is always the same Unknown most similar to female officer. She always looks the same and it happens regardless of what the tooltip says I'm getting. Annoying little bug, I would have much rather have had the human and Vulcan it said I was getting.
At least you received a bridge officer? I did not get one.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-13-2010, 06:46 AM
I've had the most trouble with requesting Bridge officers that were "rewards".

After my first bridge officer I requested a Human Science Officer then Vulcan Science Officer. The first time I received a Bolian, the second I received an Andorian. In all cases I picked a female and got a female

Now when I was at Spacedock and I requested a Male Trill Tactical officer and that's exactly what I got.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
01-14-2010, 12:46 PM
I tried to purchase an officer on the starbase, but it took my money and didn't give me anyone. Unless of course I'm just an idiot and don't realize where to look to see this person? My character interface only shows the initial officer given to you in the beginning at the transporter.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
03-14-2010, 05:29 AM
Same issue as Nullset, I dont have a clue if I should be doing something after Requisitioning officers?
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:08 AM.