Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
ok, i cant exactily reproduce this at will. But it does happen enough to be anoying. Has anyone else had their movement keys either invert or 'swap' on them durring combat on ground missions? I cant count how many times ive targeted something on the ground, shot at it.. then tried to move/straff to the right.. only to have my character either move to the Left instead.. OR... move forward/backwards instead. Its realy anoying and has almost gotten me killed a few times.

Also.. has anyone else noticed the 'walk' keybind dosnt work? You hit it and your character just stands still (almost like its a brake hehe) And that while moveing in 'aim mode'... your character looks to be 'running' in slow-motion rather than actualy walking while aiming? (sometimes you'll actualy see your avitar 'aim' down the barrle of their gun while moveing in aim-mode.. but 99% of the time they 'look' like their running in slow-motion rather than walking.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-19-2010, 11:23 AM
Yes, this happened to me last night. Well, not the situation you described, but something similar.

Last night while on a ground mission, whenever I pressed the Space Bar my character would not jump. Instead my character would do a forward roll. At the same time the Hot Keys for my Action Bar stopped working. I could not press any of the number keys (1, 2, 3 etc) to activate my abilities. I had to click on the buttons for any of them to work. When I then beamed back up to my ship, the number keys to fire my ship weapons stopped working also.

I have not changed any of the preset keybinds and when the error occurred I even checked to make sure that Space was still the button for Jump and the Keybind menu indicated that it still was.

Also, this may be unrelated, but the key binds for the Bridge Officer abilities in space seem to keep randomly changing. I had High Yield Torpedoes bound to Alt+2 when I first started but since then, without messing with the action bars or key binds, every day I'll log in and it'll be something different (Alt+5, Alt+0 etc). I've tried open up the setup with the 3 action bars (Normal, Ctrl, and Alt) but I could not figure out how to move the abilities to the keybind that I wanted. This may just be a failure on my part when trying to figure out how to move them, but they should not move on their own.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-19-2010, 03:06 PM
Yea.. it tends to happen completely randomly.. i'll make it threw an entire fight fine.. the the next fight.. kill the first 2... then on the 3rd mob, my movement keys randomize... sometimes i can 'fix' this mid-fight by untargeting everything, then re-targeting things.. but its realy anoying...

p.s. and i REALY wish they'd let us know ahead of time when their going to bring the servers down.... had just turned in a quest then 'boom' disconnected from server... try to log back in.. 'unable to authenticate' the heck?.. wait 2 mins.. try again... launcher loads up, it patches top of the corner "Server Down"... geez.. atleast give us some kinda warning?.. maybe some message from Starfleet or the Klingong high-councel that pops up to let us know your fixing to jeark the router out of the wall befor ya do?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-19-2010, 04:15 PM
Yes this happens frequently to me too.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-20-2010, 02:02 AM
Ok... i 'think' i may have found a way to reproduce this.. but since the Server was nice enough to die on us all with no warning yet again.. i cant test it and i need some sleep.. so someone else 'test' this to see if you can get it to happen consistantly?

have your avitar 'faceing' the target... Target the mob.. then attack it.. see if your controles work like normal.

Now.. here's the important part... NEXT fight you do... turn your characters AWAY from the mob.. either fully 180 away or 90 away... Now.. rotate your camera around to see the mob withough actualy turning your Avitar... then attack it (your avitar should automaticaly turn to attack it) See if your controles are suddenly all messed up.

*note* This is just a hunch.. it sorta poped into my head AFTER the server booted us all again =(.. and im heading to bed.. so someone see if this is a way to 'reproduce' it. Im betting anything that when your not actualy 'faceing' the target.. then click an attack skill.. While your 'avitar' might turn on your screen.. the 'comptuer' one dosnt turn.. .. the paper-doll the server see's is still poiting at that 180 or 90 degree differance even though your now 'faceing' it and shooting, and that is why your keys seem to be all screwed up...

Lets take the 90 deg offset as a example: If the mob isi to your right.. and you auto-attack it by useing a skill.. your avitar turns right and starts to attack.. BUT.. i be the paper-dall dosnt actualy turn.. so now.. your 'straff right' now becomes 'move forward', your straff left turns into "back up"... and so forth.. NOT because the controles suddenly scrambled themselves.. but because that is the orientation the Server remembers you haveing towards the target you are now attacking.

(i also think this is why unselecting then reselecting a target sometimes clears this up.. as when you unselect the target.. then 'move'... your avitar and paper-doll sync up again.)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-20-2010, 05:01 AM
not quiet what happened to me but close enough.. As it happens every time i get offered new skills i have to rearange my skillbar and start over again. I got 2 rows while in ship-combat and one row while in groundcombat and i have to rearange the skills as i want to have them the way i can access them easily but they change places after i get a new skill.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
01-20-2010, 02:23 PM
ok.. i tested it.. and im 100% correct.... (or veary darn close lol)

If your 'view' is off-center from your character when you auto-attack something.. your Movement Keybindings WILL BE MESSED UP (or seemingly so). 100% of the time, every time. If your not looking over your characters shoulder at the 'target' when you auto-attack.. the Avitar 'turns' to face the target.. but the Servers paper-doll DOES NOT.

Quick work-around to this.. is every time you KNOW you have attacked something not direcly in line with your charater hold down the Right mousebutton and turn slightly with the mouse while you are attacking the target (hold down on the right mouse button and slide the mouse right or left to 'turn') this will re-allign your paper-doll the server is seeing with the Avatar you are seeing. Once you do that, you can let go of the right mouse-button and use the movement keys like normal, your movement keys should also RETURN to their normal operation. (forward will be forward, back will be back, and so on.)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
04-12-2010, 03:02 PM
Quote:
Originally Posted by Boomhauer
Last night while on a ground mission, whenever I pressed the Space Bar my character would not jump. Instead my character would do a forward roll. At the same time the Hot Keys for my Action Bar stopped working. I could not press any of the number keys (1, 2, 3 etc) to activate my abilities. I had to click on the buttons for any of them to work. When I then beamed back up to my ship, the number keys to fire my ship weapons stopped working also.

I have not changed any of the preset keybinds and when the error occurred I even checked to make sure that Space was still the button for Jump and the Keybind menu indicated that it still was.
Just had this happen to my Tactical Fed Lt Commander, in a PVP match. Restarting the game fixed it, but it happened again shortly thereafter, also in a PVP match. I also checked the space bar and it's set for Jump. I sent in a bug report. Hope someone sees it.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:04 PM.