Go Back   Star Trek Online > Feedback > Builds, Powers, and Game Mechanics
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
05-14-2010, 11:25 PM
I can't take credit for this, because someone posted this in a thread I put up about this same issue.

If you wait for ~2 or more seconds after activating Beam Overload before firing, then your beams won't go offline. Ever since I've started doing that, my beams have been fine.

Also, if you REALLY need them back, just get yourself killed/abandon ship. Your beams will be back on the respawn.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
05-26-2010, 06:41 AM
Quote:
Originally Posted by mvs5191 View Post
I can't take credit for this, because someone posted this in a thread I put up about this same issue.

If you wait for ~2 or more seconds after activating Beam Overload before firing, then your beams won't go offline. Ever since I've started doing that, my beams have been fine.

Also, if you REALLY need them back, just get yourself killed/abandon ship. Your beams will be back on the respawn.
thats ok for the first time you open your weapons up on the target. But a messy work around for a bug that is having a massive impact.

The question is how much of a priority is it for the devs / coders. I would say low to non existant given new content is on the horizon and it hasn't yet been addresed.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:43 AM.