Go Back   Star Trek Online > Feedback > Federation Gameplay
Login

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Lt. Commander
Join Date: Dec 2007
Posts: 120
I accepted a couple of attache level missions from the ambassador, and it turns out, when I go to the respective clusters, the "Diplomatic Investigation" tab comes up, but all I get is the same scan mission over and over. When I check my mission log, it doesn't record me ever accepting the assignments. BUG. FAIL. A side note... Everything just seems great on Tribble, and in my opinion, something screwy must have happened when Cryptic moved the build to Holodeck because there are a few things rotten in Denmark, or should I say the B'Tran Cluster. The missions I have already accepted and returning to patrol for "Explore the B'Tran Cluster" redirect me to different systems. (similar to the Diplomatic Investigation Problem) Also, teaming in B'Tran is now defunct. I try to join the system my teammate is in, I read him in a different instance of the system I'm in, and he reads me in a different instance of the area he's in, while both of us are in two completely separate locations. BUG BUG BUG. By Surmise, the B'Tran issues may be occurring in the other clusters as well. Anyone else having these problems?
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:29 AM.