Prev Previous Post   Next Post Next
Lt. Commander
Join Date: Dec 2007
Posts: 120
Okay, I may be looking to much into this, nad this might not be the right place to post, but here I go. Why is it that certain consoles on my ship don't give me the proper bonuses.

To clarify, I fly around in the Sovereign Assault Cruiser, with my skills spec-ed into every cruiser along the way except the tier 5 one is in Star cruiser not Assault Cruiser becasue I just changed over. I put on an RCS accelerator which should have given me 28% bonus to my turn rate. it went from 10.7 to 11.6 instead of the ~13.9 it should have been.

And then I decide to ignore it, becasue if I wasn't going to get much out of it either way, I decided to put on a Neutronium Alloy which is suppose to give me a +15% bonus to both kinetic and energy damage. instead I ended up with only 13% bonus. (I understand that stacking these consoles is suppose to give me diminishing returns, but why is it giving me small returns for only placing one on?)

So my question is this, are federation cruisers suppose to loose out on the bonus of these consoles, as a from of balancing, or is this a glitch of some kind. I hardly think it's fair to limit the bonuses on cruisers for the feds when I have a fleet mate who is getting full bonuses to his Nehg'var cruiser. (With only 2 RCS accelerators, his turn rate is now a 22.)

can some one give me an answer?
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:04 AM.