Lt. Commander
Join Date: Dec 2007
Posts: 120
I did a search and did not come across this. If its been posted then my bad.

For the last 50 days now I have been unable to take any Diplomatic missions. Everytime I contact the Ambassador, I get the yellow text saying the mission was accepted and then completed and cycles out of it.

I can get to the screen where we can select the Diplomatic mission, and I can select them no issues, however the mission does not update on my screen. I have checked the other mission menus, and the Diplomatic missions are not showing.

Kind of annoying....

I have even went to the sectors where the mission takes place to see if it was just a bug, but still no missions appear.

Anyone else having this issue? Does anyone know if the there is a thread on it that I am missing?

Thanks.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
04-12-2011, 03:18 PM
I do not ever see the diplomatic mission unless it is a First Contact in my J log.

And I read somewhere you only have 30 minutes to get to the explore teritory. Then in the lower right you will see a small warp button and a larger diplomatic mission button (where the OP messages hide)
Click the diplomatic missioin and it begins.

I think it doesn't list because you have a limited amount of time to reach it.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:38 PM.