Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Fatal Error decompressing data
12-26-2011, 02:43 PM
I consistently keep getting STO crashing to desktop randomly while playing. Its become incredibly frustrating, and tiresome. I have ploweed through these forums and google for an answer and have come up pretty much empty handed despite following advice given by randoms in threads of other forums and here.

What I am however consistently seeing is the words "Windows 7" and "x64" mentioned in alot of these, and while a certain helpful IT person has chimed in on here in other threads claiming the problem may be RAM, faulty CPU or dying hard-drives, I pretty much prefer the "Occams-Razor" approach to troubleshooting rather than the seemingly "blame everyone else bar our lacklustre programming" mentality.

I'll cut through the hand-holding and say it's absolutely not on my end, but is a result of STO notbeing able to communicate with x64 Windows 7 systems. It's as simple as that. Since this issues seems to be common (just search "fatal error" on the forum to see for yourself), It would be splendid if Cryptic actually address this shortcoming and make this game actually playable.

and yes Ive reinstalled and downloaded the game twice, this has absolutely nothing to do with corrupt .hogg files.

From the gameclient immediately following a crash:

"preloading DLLs...done.
Filesystem startup...
Loading hoggs...done (-1 hoggs)
GameDataDirs:
*.
Auto-enable PatchStreaming... disabled (no NotRequired in filespec)"

The actual popup following the crash to desktop:

"Fatal error: Error decompressing data. Verifying files in the launcher may fix this issue:
Technical Details: Error decompressing data. Verifying Files in the launcher may fix this issue:
Texture_Library/costumes/avatars/female/f_hair_andorian_short_06_N.wtex"

The actual cited texture will change on every crash.

Further gameclient information:
"Unable to find required game data files. If this problem persists, reinstalling the application may fix the situation"

List of approaches undertaken to solve this issue:
Deleted the entire piggs folder, and redownloaded from launcher x2 CHECK
Deleted STO from hardrive and reinstalled from Steam x1 CHECK
Manually closed every superflous running program via taskmanager before launching game: x2 CHECK
Teamspeak: Not Installed
Ran game launcher via steam: x10 CHECK
Ran game launcher without steam x5 CHECK
Ran Game Launcher and Game .exe as administrator x5 CHECK
Reinstalled STO to entirely new folder from" Program Files" to "Program Data" CHECK
Backedup entire piggs folder on reinstallation and replaced "corrupted" hoggs when they become modified in-game (TIMESTAMPED, this occurs in the problem file) x3 CHECK
checked and unchecked "Read-Only" .hogg files in piggs folder x4 CHECK
Updated graphics card drivers to recent release x1 CHECK

Now, speaking of Occams Razor, which of the following scenarios is the most likely problem?
Users with Windows 7 x64 systems ALL have one of the following: faulty RAM, Hard-drive, CPU et al, preventing them playing STO.

Or

Users with windows 7 x64 systems are suffering because STO programming is not properly communicating with said system.

I'm hoping someone actually can provide me with a solution to this other than fobbing me off with the same tired and used rhetoric of "it's a problem with your system".

FYI: This computer system is brand new, and with all other programs I use on here, STO is the only game that I'm continually experiencing problems with. Consider this, please.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
12-26-2011, 02:55 PM
I don't think STO has been fully upgraded for win 7 yet.
what kinda Video card do you have

But if you want too check your Ram
http://www.memtest86.com/
Or get it from here
http://majorgeeks.com/Memtest86_d4226.html
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
12-26-2011, 03:05 PM
Quote:
Originally Posted by Xcom46 View Post
I don't think STO has been fully upgraded for win 7 yet.
what kinda Video card do you have

But if you want too check your Ram
http://www.memtest86.com/
I will check that out, just to rule it out, but to be brutally honest, I see these coincidences on the forums revolving around this exact same issue, and approximately 90% of all the reports also come from users with windows 7 systems. What I dislike in almost all of these cases is the implication that THEY are to blame with some faulty hardware, without condeeding that STO's programming is in-fact to blame.

I don't therefore think that of the 25 or so cases on this forum alone ive read reporting this error all have the same hardware failure, it's statistically improbable.

Thankyou for your input though, especially taking the time to provide a link
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
12-26-2011, 03:15 PM
Link is not that hard to find lol i know a crap load of sites .

But if you all so want too clean out the bugs try ASC 5 its free too use but if you pay for a Lciensing its only 20$ for a whole year

http://www.iobit.com/download.html
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
12-26-2011, 05:23 PM
I run under win 7 64 and have never had a crash. Of course I don't not
1. have the game running under steam
2. have the game installed in the program files folder.

Quote:
Quote from coderanger....

Fun fact, the game will break pretty frequently if you install to Program Files under Vista or Win7 because of a new security feature called Virtual Store (short version: it intercepts and rewrites file writes inside prog files to go somewhere else). That is why it is no longer the default install location on those platforms. There is no permanent way to disable this feature of Windows, so installing outside of Program Files is the best option. The "correct" place according to MS for this would be C:\ProgramData, but more games use Users\Public\Games that we wanted to go with the clearer one. The More You Know.
3. use an antivirus program that will corrupt the hogg files on downloads or lock the file under scanning
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
12-27-2011, 07:35 AM
Quote:
Originally Posted by PegasusMD
I run under win 7 64 and have never had a crash. Of course I don't not
1. have the game running under steam
2. have the game installed in the program files folder.



3. use an antivirus program that will corrupt the hogg files on downloads or lock the file under scanning
1: I've launched in and out of steam repeatedly
2: I don't have the game installed to the "Program Files" folder (see original post), in fact it's located on completely seperate partition.
3. I don't have any anti-virus installed, Win7 was installed less than 2 days ago on a brand new system. This includes motherboard, CPU, Power Unit, Hard-drive,RAM and CD drives. All of these were tested before i received them as well as tests ive done myself, including the memtest that was linked to me above.

Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
12-27-2011, 08:32 AM
i had similar issues over a year ago now. it was for me a faulty ram stick that caused all the issues
And yes i run windows 7 64bit
10gb ram
ati 6970 12.1 beta drivers
core i5
soundblaster fatality
etc.....
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
12-27-2011, 01:50 PM
Ive ran memtest about 8 times and it found no issues with RAM problems.

I've submitted a ticket to hopefully get this sorted. In the meantime this issue, which is a known one, is not new:

http://forums.startrekonline.com/sho...d.php?t=114468
http://forums.startrekonline.com/sho...d.php?t=177379
http://forums.startrekonline.com/sho...d.php?t=238232
http://forums.startrekonline.com/sho...d.php?t=183547
http://forums.startrekonline.com/showthread.php?t=68569
http://forums.startrekonline.com/sho...d.php?t=146209
http://forums.startrekonline.com/sho...d.php?t=244855
http://forums.startrekonline.com/sho...d.php?t=218330
http://forums.startrekonline.com/showthread.php?t=56238
http://forums.startrekonline.com/sho...d.php?t=243099
http://forums.startrekonline.com/sho...d.php?t=105995
http://forums.startrekonline.com/sho...d.php?t=163524
http://forums.startrekonline.com/sho...d.php?t=159186
http://forums.startrekonline.com/sho...d.php?t=135135
http://forums.startrekonline.com/showthread.php?t=56802
http://forums.startrekonline.com/sho...d.php?t=229281
http://forums.startrekonline.com/sho...=110507&page=3
http://forums.startrekonline.com/sho...d.php?t=105166
http://forums.startrekonline.com/sho...=56238&page=14

EXACT same issue in Champions Online:
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
http://forums.champions-online.com/s...mpressing+data
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
12-28-2011, 10:19 AM
Bumping, as this is still relevant. The problem persists with crashes to desktop.
recent logs:
111227 20:47:31 37 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Costumes/Avatars/Tng/M_Uniforml_Tng_01_S.Wtex:
111227 20:53:52 15 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Costumes/Avatars/Tng/M_Uniforml_Tng_01_S.Wtex:
111227 20:55:49 15 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Costumes/Avatars/Tng/M_Uniforml_Tng_01_S.Wtex:
111227 21:23:35 72 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Environment/1_Assets/Lava/Space_Lava_01_D.Wtex:
111227 22:29:59 42 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Environment/1_Assets/Lava/Space_Lava_01_D.Wtex:
111227 22:41:31 18 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Environment/1_Assets/Lava/Space_Lava_01_D.Wtex:
111228 18:18:10 57 Client[0]: Error decompressing data. Verifying Files in the launcher may fix this issue.: Texture_Library/Costumes/Avatars/Animals/S_Spider_D.Wtex:

Every instance where a new texture error appears is AFTER the hogg files are redownloaded/replaced.

Vivox Log:
111228 18:08:10 39 Client[0]: Error - VivoxClient::WatcherInfoBuddy::OnSubscriptionConte ntChanged: 012-28-11 18:08:10.509 3464 Error C:\src\buildtools\branches\voon\tmp9glu5z\src\vivo x.client\watcherinfobuddy.cpp 163 VivoxClient::WatcherInfoBuddy::OnSubscriptionConte ntChanged vr=3069
111228 18:08:10 40 Client[0]: Error - VivoxClient::WatcherInfoBuddy::OnSubscriptionConte ntChanged: 012-28-11 18:08:10.509 3464 Error C:\src\buildtools\branches\voon\tmp9glu5z\src\vivo x.client\watcherinfobuddy.cpp 263 VivoxClient::WatcherInfoBuddy::OnSubscriptionConte ntChanged this=0x2535b5e0,vr=3069
111228 18:09:45 51 Client[0]: Warning - VivoxSystem::MessageRouter::UnregisterHandler: 012-28-11 18:09:45.930 3464 Warning C:\src\buildtools\branches\voon\tmp9glu5z\src\vivo x.system\messagerouter.cpp 143 VivoxSystem::MessageRouter::UnregisterHandler attempt to unregister non existent handler - id=104
111228 18:09:45 52 Client[0]: Warning - VivoxSystem::MessageRouter::UnregisterHandler: 012-28-11 18:09:45.930 3464 Warning C:\src\buildtools\branches\voon\tmp9glu5z\src\vivo x.system\messagerouter.cpp 143 VivoxSystem::MessageRouter::UnregisterHandler attempt to unregister non existent handler - id=105

111226 22:54:16 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/costumes/Avatars/Female/F_Hair_Andorian_Short_06_N.wtex:
111226 22:54:16 3 InvalidType[1]: Read wrong number of bytes: texture_library/costumes/Avatars/Female/F_Hair_Andorian_Short_06_N.wtex: 13
111227 01:22:35 2 InvalidType[1]: File read from disk has bad CRC. Verifying Files in the launcher may fix this issue.: bin/DynFx.bin: 20
111227 18:25:57 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/costumes/Avatars/Uniforms/M_UniformU_Jupiter_04_C.wtex:
111227 18:25:57 3 InvalidType[1]: Read wrong number of bytes: texture_library/costumes/Avatars/Uniforms/M_UniformU_Jupiter_04_C.wtex: 13
111227 18:40:16 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/Space/Props/SpaceStations/KlingonStation_01_NS.wtex:
111227 18:40:16 3 InvalidType[1]: Read wrong number of bytes: texture_library/Space/Props/SpaceStations/KlingonStation_01_NS.wtex: 13
111227 20:48:25 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/costumes/Avatars/TNG/M_UniformL_TNG_01_S.wtex:
111227 20:48:25 3 InvalidType[1]: Read wrong number of bytes: texture_library/costumes/Avatars/TNG/M_UniformL_TNG_01_S.wtex: 13
111227 20:54:32 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/costumes/Avatars/TNG/M_UniformL_TNG_01_S.wtex:
111227 20:54:32 3 InvalidType[1]: Read wrong number of bytes: texture_library/costumes/Avatars/TNG/M_UniformL_TNG_01_S.wtex: 13
111227 21:23:49 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/environment/1_Assets/Lava/Space_Lava_01_D.wtex:
111227 21:23:49 3 InvalidType[1]: Read wrong number of bytes: texture_library/environment/1_Assets/Lava/Space_Lava_01_D.wtex: 13
111227 22:36:02 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/environment/1_Assets/Lava/Space_Lava_01_D.wtex:
111227 22:36:02 3 InvalidType[1]: Read wrong number of bytes: texture_library/environment/1_Assets/Lava/Space_Lava_01_D.wtex: 13
111227 22:41:43 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/environment/1_Assets/Lava/Space_Lava_01_D.wtex:
111227 22:41:43 3 InvalidType[1]: Read wrong number of bytes: texture_library/environment/1_Assets/Lava/Space_Lava_01_D.wtex: 13
111228 18:18:30 2 InvalidType[1]: Error decompressing data. Verifying Files in the launcher may fix this issue.: texture_library/costumes/Avatars/Animals/S_Spider_D.wtex:
111228 18:18:30 3 InvalidType[1]: Read wrong number of bytes: texture_library/costumes/Avatars/Animals/S_Spider_D.wtex: 13

Either something is corrupting the hogg file in question EVERYTIME the client is launched, or the program is not reading the file as it should be.
Ensign
Join Date: Jul 2012
Posts: 21
# 10
12-05-2012, 01:51 PM
yea have the same problem, wtex error's !!! its making me sick!
and stop giving players the standard reply "ITS YOUR COMPUTER" well Bugger-off cryptic its YOUR BLOODY FILE-HANDLING, does your game really need to decompress the same file over and over and over and yes OVER, GOT DAM I HAVE PLENTY OF RAM GIVE US AN OPTION TO LET IT ALL LOADED FOR FOK SAKE! see you made me mad again and its not that i have this problem once, NOOooooooo i have this problem from the start of the game, this is even my second computer i have it on so quit the crap "its your ram, HD, computer" and take a real LOOK in to this problem. Oh wait you guys foked up the code that bad its gonna be a complete rewrite of the engine eh! ... yah thought so. yet one more snip of bad new we Lifetimers have to eat eh! Thanks CRYPTIC for a GREAT CRAPY GAME.

now return my lifetime sub + intrest and i'm happy OR try to fix it.

and NO i'm not sending in the dump again, i'v done that 1GB upload more then plenty of times.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:40 AM.