Lt. Commander
Join Date: Dec 2007
Posts: 120
OK, there is some WEIRD sh*t going on with low poly *far away* LOD Models of Spaceships in this game.

The Sovereign, Galaxy, Defiant High poly models were redone by Logan, but the low poly versions were not touched, so these ships even change their Shape while going into low poly mode (which was VERY visible in the Facility 4028 Episode Cutscenes)

The K'tinga was redone once a long time ago to have glowing Warp Engines and Mission Pod, then for some odd reason low and high poly models were swapped and now it only glows when the camera is FAR AWAY, and doesn't glow at all when you are near it. (which i told logan multiple times, but never was fixed because of stupid schedule stuff)

http://s14.directupload.net/images/120401/468rgqqw.jpg
http://s1.directupload.net/images/120401/xhahirqf.jpg



BUT THIS ONE... really wins the PRICE of most redonkulous High / Low Poly LOD swap glitch.


It's one of the 3 C-Store Gorn Ships, no idea what the name is, but LOOK at these pics:

http://img6.imagebanana.com/img/1d4f...0401031213.jpg

http://img7.imagebanana.com/img/anx4...0401031158.jpg
http://img7.imagebanana.com/img/be0j...0401031159.jpg

http://img6.imagebanana.com/img/m29h...0401031202.jpg
http://img7.imagebanana.com/img/var9...0401031203.jpg

http://img6.imagebanana.com/img/lwcq...0401031221.jpg
http://img6.imagebanana.com/img/t58h...01031221_1.jpg

(that isn't even the same ship model is it?)

man am i glad that i didn't buy the Gorn Ships, i would not want to fly around in a bugged ship like that.


Maybe Jamz Jamz can finally fix this stuff up ??
if he isn't to busy creating the next 10 C-Store or Lock Box Ships :p
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-31-2012, 08:32 PM
Looks like the Varanus. It used to be much larger than it is currently, they must have not changed the size of the low-detail model. It would be nice for this to change, I have a gorn who'll be able to use this ship soon.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-31-2012, 09:17 PM
It's something I've noticed with quite a few of the recent +1 ships on all sides. I've seen the Gladius turn into sabers, Thunderchilds into Akiras, there seems to be some sort of issue with the far distance models of the +1 ships, like they've not been loaded in properly or something. But this, turning into an entirely different base class, is something new.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
04-01-2012, 02:55 AM
Quote:
Originally Posted by CptBANG View Post
OK, there is some WEIRD sh*t going on with low poly *far away* LOD Models of Spaceships in this game.

The Sovereign, Galaxy, Defiant High poly models were redone by Logan, but the low poly versions were not touched, so these ships even change their Shape while going into low poly mode (which was VERY visible in the Facility 4028 Episode Cutscenes)

The K'tinga was redone once a long time ago to have glowing Warp Engines and Mission Pod, then for some odd reason low and high poly models were swapped and now it only glows when the camera is FAR AWAY, and doesn't glow at all when you are near it. (which i told logan multiple times, but never was fixed because of stupid schedule stuff)

http://s14.directupload.net/images/120401/468rgqqw.jpg
http://s1.directupload.net/images/120401/xhahirqf.jpg
I think there were a whole lot of people who talked with Logan about this.
And Cryptic actually fixed it.
Logan kept his promise to me and talked to the people in charge of it.
And they fixed it...two weeks before the release of Season 5 when they broke it again.
So in the year 2011 we had for alotogether about a month a properly working K't'inga model.
That's why I consider STO's QA to be something mythical like the Yeti, Big Foot and the Loch Ness monster.


Overall the LoD problems with some of the ships have been around since the launch of the game.
On my first Fed engineer I still have issues with the LoD of my Star Cruiser:
at a certain distance the type of pylon on one of my ship's nacelles suddenly changes so I end up with one nacelle under and one above the secondary hull.
So another point for quality.

But yeah, this Varanus glitch is certainly impressive.
I never noticed this one, probably because I never zoomed away from mine to such a degree.
Good catch.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
04-01-2012, 02:55 PM
I think the Galaxy-class still uses the old "far away" LOD model from launch too.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 02:49 AM.