Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
It appears that the Field Generators are not boosting the shield capacity on my Dreadnought. When I put the FG's on any of my other ships I see the shield capacity go up, but it stays static on the Dreadnought.

nevermind, must've been a glitch every time I looked at it before, just checked after the patch and all is working as it should.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-04-2012, 09:33 AM
One thing I noticed is if my captain is planetside (ground) and I try to check ship stats in the Status Window (U), the stats do not seem to reflect any changes in consoles, skills etc. I assume these stats are then base stats of some sort.

If my captain beams to his ship and I check the ship stats in the same Status Window, everything seems to work fine. Add a Field Generator console and the facing shield numbers increase immediately. Look at the ship's movement stats and crank up the impulse engines in system space and the ship's flight speed and turn rate change in real time to match the new settings.

Another good source of stats is the Available Skills (P) window. Click a weapon or shield buff skill and you should see fairly accurate numbers for the buffs and debuffs.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:57 AM.