Lt. Commander
Join Date: Dec 2007
Posts: 120
Can't seem to find them anywere?

I use to go to Zenas Expanse and pic one up every two days...because of the cool down but now i can't seem to get them at all. Been almoust two weeks now with nothing.

Anyone else having this problem?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-24-2012, 06:59 AM
Quote:
Originally Posted by goltzhar
Can't seem to find them anywere?

I use to go to Zenas Expanse and pic one up every two days...because of the cool down but now i can't seem to get them at all. Been almoust two weeks now with nothing.

Anyone else having this problem?
i have same problem... its a bug? i go to all nebulas and clusters in beta ursae but nothing i have this mission every monday

Whats happen? i need make consoles prototype....
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
05-24-2012, 07:12 AM
It seems to appear after 3 days since taking the last, and at random times.

Chances are you simply missed the assignment...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
05-24-2012, 07:13 AM
Are you looking for the Strange Alien Artifact? If is, it;s now available from a number of different doff missions:

http://www.stowiki.org/Strange_Alien_Artifact
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
05-24-2012, 07:27 AM
Quote:
Originally Posted by theapparatus View Post
Are you looking for the Strange Alien Artifact? If is, it;s now available from a number of different doff missions:

http://www.stowiki.org/Strange_Alien_Artifact
Yes it's Strange Alien Artifact, I have tried them but they does'nt seem to work.

Has anyone got Strange Alien Artifact from them please post! And I know you have to crit them!

But i wonder what has happend to that specific misson.. No notes in patchnotes..
The Ninja has been busy.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
05-24-2012, 07:30 AM
I had it 2 days ago... So it's not been removed.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
05-24-2012, 07:34 AM
Quote:
Originally Posted by anazonda View Post
It seems to appear after 3 days since taking the last, and at random times.

Chances are you simply missed the assignment...
Not a chance! that i missed them.. been playing them for 1-2 months now like clockwork and suddenly they dissapear!

Have two char's and never had any problem getting them..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
05-24-2012, 07:36 AM
Quote:
Originally Posted by anazonda View Post
I had it 2 days ago... So it's not been removed.
Thanx! Good to know.. but something has changed.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
05-24-2012, 02:18 PM
Quote:
Originally Posted by goltzhar
Yes it's Strange Alien Artifact, I have tried them but they does'nt seem to work.

Has anyone got Strange Alien Artifact from them please post! And I know you have to crit them!
.


I have. A crit seems to give a random item from either traces or the artifact. I've gotten both from the 20h science archeology missions.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
05-26-2012, 09:38 AM
History recorded that you destroyed the Uthat.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:52 AM.