Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Captain
Join Date: Jun 2012
Posts: 511
Moved a console off my ship into inventory so i can drag it to exchange to do the name real quick of somit i want another one of. I did this 5-10 mins ago and its still not in my inventory.

Also i tried to transfer 1mill + from my shared acc bank to my char and thats taking forever as well.

Tried opening a fed doff pack from a mission and that took about 10 mins or more.

Hope this is resolved soon.
Survivor of Romulus
Join Date: Jun 2012
Posts: 1,456
# 2
07-12-2012, 03:11 PM
Yeah, this tends to happen when the server is under strain. Replicator isn't working either, or rather, it is, but very slowly. I'm going to end up with a million shield generators by the time it catches up with my frantic clicking :blush:
Captain
Join Date: Jun 2012
Posts: 2,007
# 3
07-12-2012, 07:27 PM
Quote:
Originally Posted by topset View Post
I'm going to end up with a million shield generators by the time it catches up with my frantic clicking :blush:
Funny, same item here.
---
Took 20 minutes to get that screencap and her arm is still doing through the armrest
Dr. Mike's Steak Dinner

35 Starbase Projects done. 715 Projects remaining
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:21 PM.