Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Jun 2012
Posts: 155
# 11
08-07-2012, 12:06 PM
Whining?? i dont think so from my statements but W/E man .
how much effort does it take to have a community rep , just let us know that they know there is a issue that there working on it ?other times they have done this when something breaks why not this time ??? doesnt make sense .

.
Captain
Join Date: Jun 2012
Posts: 622
# 12
08-07-2012, 12:13 PM
Quote:
Originally Posted by johnmasters View Post
It may suck but the reality is you may not always have the part on hand to fix the problem right away. Not letting us know whether or not they've started work is annoying but the reality is they're probably working on it and haven't taken the time to do so.

This is prime time for me as well. My fleet needs the FM too. However being impatient and angry doesn't get anything done and only makes things worse when you complain. I know that's what the forums can be for but it doesn't help.

Bringing things to their attention is not complaining but constantly whining doesn't resolve anything.

Actually, Cryptic does a fairly decent job of avoiding and ignoring the forums. While posts may not resolve anything, it is fair to state posts are incapable of making anything worse.
All cloaks should be canon.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:30 PM.