Go Back   Star Trek Online > Feedback > The Art of Star Trek Online
Login

Reply
 
Thread Tools Display Modes
Commander
Join Date: Jul 2012
Posts: 487
Remember last September, when you released the Venture class ship on the C-store (back when it was a C-store)? I bought it because it looked beautiful, like a Galaxy should have looked from day one (although I still like the original nacelles and pylons, but that's just me).

Imagine my surprise when, while trying to customize the ship you sold me, I noticed all the windows were broken. I had blue windows on the neck, beige windows on the engineering hull, and half the windows under the saucer were simply missing. I realize this is minor, but I paid real money for this thing.

Now...fast-forward one year into the future. Is this thing fixed? No. It's still broken. You've added a bunch more ships to the C-store, and I've supported your company with further purchases, with the hope that you'd fix the one you sold me.

But it isn't fixed. It's still broken. Sure, it's only a visual change...but it's a visual change we paid for with real money, since there wasn't a way to earn Cryptic Points in-game back then. In essence, something you sold us was not as advertised, and we want it fixed, especially since the Fleet Exploration Cruiser is on the horizon...yet another thing on which you expect many of us to spend real money.

I'm not complaining about the quality of the ship (one of the more beautiful ships in the game, if you ask me), and I have very few complaints about the game in general...but please, PLEASE, tell us when you plan to fix this thing. The ships are the real stars of Star Trek Online, IMHO; they need more attention to detail than this.
Career Officer
Join Date: Jun 2012
Posts: 154
# 2
08-20-2012, 11:15 PM
Unfortunately, the cryptic responses to questions like this are not what you would like to hear. Since its a visual bug and not a game breaking bug, it will be on the bottom of bug fixes to get done. Also, since its a zen store ship (cryptic store), it would cost them $ to go back and hire/use staff to go back and fix a graphical issue that probably wont bring back more income to cover the cost to fix the issue.
Commander
Join Date: Jul 2012
Posts: 487
# 3
08-21-2012, 03:55 AM
Quote:
Originally Posted by chi1701d View Post
Unfortunately, the cryptic responses to questions like this are not what you would like to hear. Since its a visual bug and not a game breaking bug, it will be on the bottom of bug fixes to get done. Also, since its a zen store ship (cryptic store), it would cost them $ to go back and hire/use staff to go back and fix a graphical issue that probably wont bring back more income to cover the cost to fix the issue.
This isn't a complex issue that requires the model to be tweaked; we're talking a quick window fix. It's really simple:

1. Add the windows to the part where they're missing.
2. Make all the windows the same colour.

Having done modelling and texturing work for a mod that is presently nearing completion, I can tell you that a quick edit of the window layer, and a joining of the window layers between the different pieces, wouldn't take one person very long.

Frankly, I'd fix it for free, if they'd allow me to do so. I just want my ship to not look like I stole someone else's saucer, lol.
Starfleet Veteran
Join Date: Jun 2012
Posts: 274
# 4
08-21-2012, 12:47 PM
What makes it worse is - the mismatched windows - is just a linked texture error. If you have the Dreadnought, you can see that you can edit which windows you're using without any problems. Meaning finding the texture error and replacing the code would be a three, maybe four minute fix. Mirroring the texture to correct the missing windows on the bottom of the saucer? Fifteen minutes, maybe.

It's almost inexcusable that the errors have been allowed to exist on the Venture for this long. It's the most beautiful of all the '2409' ships, and has the worst texture errors...
Starfleet Veteran
Join Date: Jun 2012
Posts: 281
# 5
08-21-2012, 01:56 PM
Quote:
Originally Posted by aethon3050 View Post
This isn't a complex issue that requires the model to be tweaked; we're talking a quick window fix. It's really simple:

1. Add the windows to the part where they're missing.
2. Make all the windows the same colour.

Having done modelling and texturing work for a mod that is presently nearing completion, I can tell you that a quick edit of the window layer, and a joining of the window layers between the different pieces, wouldn't take one person very long.

Frankly, I'd fix it for free, if they'd allow me to do so. I just want my ship to not look like I stole someone else's saucer, lol.
They got your money, dude. You can't unring a bell. My saucer still shoots phasers, when separated, even though it's armed with disruptors. Bugs the crap out of me to the point, where I don't want to even seperate it. At some point in the far, distant, future, when Cryptic learns the point of patching is supposed to be fixing, not breaking, stuff, maybe it'll get addressed. Or not. Don't hold your breath.
Commander
Join Date: Jul 2012
Posts: 487
# 6
08-21-2012, 07:19 PM
Quote:
Originally Posted by mkilczewski View Post
They got your money, dude. You can't unring a bell. My saucer still shoots phasers, when separated, even though it's armed with disruptors. Bugs the crap out of me to the point, where I don't want to even seperate it. At some point in the far, distant, future, when Cryptic learns the point of patching is supposed to be fixing, not breaking, stuff, maybe it'll get addressed. Or not. Don't hold your breath.
And we guarantee it'll never be fixed if we shut up and never say anything, because that would tell Cryptic we don't care.
Commander
Join Date: Jul 2012
Posts: 487
# 7
08-29-2012, 10:28 PM
Another week, another set of patch notes, still with nothing on this issue. Still no response, still no ETA, still a broken ship, and we're just a couple days away from the 1 year anniversary of the day I spent money on this ship.

I'm seeing new uniforms, free desktop wallpapers, and even concept art for stuff from season 7. Can you please take a few minutes and fix the ship you sold us a year ago?

If you do, I shall sing you the song of my people. Seriously, if you get on Teamspeak with me, I will sing it for you. I could also dance the dance of my people for you, but that would require a webcam, and it would probably start getting kind of creepy at that point.
Ensign
Join Date: Jul 2012
Posts: 17
# 8
08-30-2012, 04:29 PM
I'm posting to support you, but don't hold yer breath.

I have two officers on my bridge with belts/shirts the same colour, and rank pips/com badges the same colour because for whatever reason their colours are linked. Change one, it changes them both.

Same uniform options on other characters are normal and not linked.

Added: And just to note, other large MMO companies with larger games *cough* Wow *cough* have out waited me with model updates. The original Druid cheetah "travel" form was a placeholder graphic at launch in 2004, but did not get updated until recently. I left that game long before then. (although not because of that tiny issue)

Last edited by stockwellday; 08-30-2012 at 04:31 PM.
Ensign
Join Date: Jun 2012
Posts: 4
# 9
08-31-2012, 07:15 AM
Simple fix: Complain long enough and they will fix it.


Trust me on this XD
Career Officer
Join Date: Jun 2012
Posts: 6,036
# 10
08-31-2012, 07:21 AM
No need... they have your money, and as such have no need to make the ship better.
My name may say "PWE member", but I will never be.
-NEVER Forget the Screwups and ignorance made towards the people who supported the game through 2011
Don't look silly, don't call it "Zen-Store" - Don't waste devs time, Post proper bug-reports - I don't like Gekos
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 07:41 PM.