Career Officer
Join Date: Jun 2012
Posts: 152
# 71
10-04-2012, 11:33 PM
Quote:
Originally Posted by jacktaye View Post
Hey like a lot of people here, I want to thank you for making STO work on OS X. I'm a big Trekkie and a big gamer, and when I decided to switch to Mac I was dismayed that the game didn't run on Mac. I've just got a quick question. I recently upgraded to Mountain Lion and now the game isn't working anymore. This happened earlier when I upgraded to Lion but it worked okay afterwards. This time it wouldn't even turn on anymore. Should it work on ML?
of course it works on ML.

Occasionally permissions get messed up and the wrapper won't work right through an upgrade. Try getting a new copy of the wrapper and moving the Cryptic Studios from the old wrapper to the new wrapper and see if it works.
Captain
Join Date: Jun 2012
Posts: 3,261
# 72
10-05-2012, 09:13 AM
My computer is encouraging me to install "Mac OS X v10.7.5 Supplemental Update". Seeing as the first one screwed up Wineskin, is this one safe to download?
"It's not safe out here. It's wondrous, with treasures to satiate desires both subtle and gross. But it's not for the timid."
-- Q
Career Officer
Join Date: Jun 2012
Posts: 152
# 73
10-05-2012, 05:51 PM
Quote:
Originally Posted by psycoticvulcan View Post
My computer is encouraging me to install "Mac OS X v10.7.5 Supplemental Update". Seeing as the first one screwed up Wineskin, is this one safe to download?
it should be fine... its just a couple patches that don't involve anything related to Wineskin.

The kind of error that happened with 10.7.5 and 10.8.2 was the first of its kind to break a Wineskin wrapper since the first version of 10.4 for Intel Macs (first ever Intel Macs)... the chances of something happening like that again are extremely low.
Ensign
Join Date: Jun 2012
Posts: 15
# 74
10-06-2012, 12:29 AM
Quote:
Originally Posted by therealdoh123 View Post
that is the downloader program... not the actual game... your right it doesn't work.

If its already installed there will be an exe file in the Cryptic Studios folder called Star Trek Online.exe which is what needs to be ran. Just make sure the Cryptic Studios folder is inside the wrapper in Program Files, and make sure thats the exe that is selected to run in Advanced Configuration tab. If you don't have the game installed, you need to download the actual full game and not use that downloader program.
Oh, OK. I didn't know it was just the downloader and not the actual game. So how do I get the actual game in there?
Career Officer
Join Date: Jun 2012
Posts: 152
# 75
10-06-2012, 06:06 AM
Quote:
Originally Posted by jaywest21 View Post
Oh, OK. I didn't know it was just the downloader and not the actual game. So how do I get the actual game in there?
if you already have the game installed somewhere, you can simply make a copy of the "Cryptic Studios" folder its installed to...

If you do not and you need to actually install the game, you need to find a full game download. That means either the torrent download, or go somewhere like FilePlanet.com which has full downloads. Once you have the full game you can run its setup.exe file to do the install into the wrapper.
Ensign
Join Date: Jun 2012
Posts: 15
# 76
10-07-2012, 01:17 AM
Thanks again; I appreciate all your help thus far.

I finally managed to install the game, but it still doesn't work. I followed all the instructions to the letter, and... nothing. I tried doing as you said and going into Wineskin to go to reconfigure the Advanced settings, and it doesn't work either. When I click on Wineskin, I can't even get into it. It just says "Wineskin is busy" and keeps spinning, like it's stuck somehow.

I click on the STO app and nothing happens. It looks like it's trying to launch the game for a split second, and then nothing. I am at my wit's end here. I don't understand why even after it successfully installed, it still won't work, when it worked OK last time I installed it.

Is there anything else I need to do that I haven't done already?
Career Officer
Join Date: Jun 2012
Posts: 152
# 77
10-07-2012, 04:47 AM
Quote:
Originally Posted by jaywest21 View Post
Thanks again; I appreciate all your help thus far.

I finally managed to install the game, but it still doesn't work. I followed all the instructions to the letter, and... nothing. I tried doing as you said and going into Wineskin to go to reconfigure the Advanced settings, and it doesn't work either. When I click on Wineskin, I can't even get into it. It just says "Wineskin is busy" and keeps spinning, like it's stuck somehow.

I click on the STO app and nothing happens. It looks like it's trying to launch the game for a split second, and then nothing. I am at my wit's end here. I don't understand why even after it successfully installed, it still won't work, when it worked OK last time I installed it.

Is there anything else I need to do that I haven't done already?
If Wineskin.app is just spinning its wheel and nothing is happening... there could be something screwed up in the wrapper. Its not worth trying to narrow down. Just take a clean new one, and move the Cryptic Studios folder it installed over to the new wrapper... no re-installation needed.
Ensign
Join Date: Jun 2012
Posts: 15
# 78
10-08-2012, 12:46 AM
Quote:
Originally Posted by therealdoh123 View Post
If Wineskin.app is just spinning its wheel and nothing is happening... there could be something screwed up in the wrapper. Its not worth trying to narrow down. Just take a clean new one, and move the Cryptic Studios folder it installed over to the new wrapper... no re-installation needed.
OK, thanks, I'll try that.
Ensign
Join Date: Jul 2012
Posts: 16
# 79 wineskin!!!
10-08-2012, 11:04 PM
omg dude now I have been regretting this apple thing mackbook pro lap i7 forever it seems and all i had to do was search the forum to find that utility windskin ... ,, I am downloading and installing - they even have a picture of the sto character creation screen at wineskin

If there are problems with the install/download/running I will be back to this corner of the forum
Career Officer
Join Date: Jun 2012
Posts: 152
# 80
10-09-2012, 05:48 AM
Quote:
Originally Posted by podlex View Post
omg dude now I have been regretting this apple thing mackbook pro lap i7 forever it seems and all i had to do was search the forum to find that utility windskin ... ,, I am downloading and installing - they even have a picture of the sto character creation screen at wineskin

If there are problems with the install/download/running I will be back to this corner of the forum
really old picture on the website.. I haven't updated those in a couple years... but yeah, the one is a really old STO shot :-P Have some Baldurs gate and Neverwinter Nights and a Might and Magic shot.... all RPGs, guess you can tell I like RPGs :-)

Just post if you have problems... you will probably have random crashes... not much I've been able to do about those, but it works good most of the time. It also may take like 10 minutes to do a log in after a patch... sitting on the Loading screen... annoying, but shouldn't happen again until you get another patch.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:00 AM.