Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Ensign
Join Date: Jun 2012
Posts: 25
I recently upgraded my Orion Slavers that I had on my carrier to the Advanced version. (I have one bay with slavers, and one with To'Duj fighters). When I went into an STF after the upgrade my slavers had captured 4 contraband, some EC, and various other odds and ends. After the match, I logged out of the game and went to bed. From that point on (going on 2 weeks now) they have not captured another item at all. No EC, no contraband, no particle traces, nothing.

I thought it odd, so I swapped back to my original non-upgraded slavers to see if they still worked, and they too have stopped collecting items.

Just wondering if anyone else has been having lazy slavers, or if perhaps there has been a bug introduced with one of the weekly patches. (or maybe it is just me...)

I would really hate to have ground out 32K dil for the slavers if they won't collect anything. (I am at 23K dil towards getting another flight of advanced slavers for my other bay, but may hold off on that purchase if they are bugged...)

Any input or suggestions are appreciated.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:22 AM.