Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Career Officer
Join Date: Jun 2012
Posts: 120
I have encounterd so many bugs since season 7 was relased. I understand why they do niot want us to do the quickies for investigate officer reports but i can not even get a single mission to complete, yet when i play the game seems every now and then 1 auto completes. The doff screen is bugged , every time i start a doff mission the thing jumps back to the top avalible mission .wasn't this a problem in season 6 and didn't they fix it? When equipping my hypo's from inventory to my device slots after they have all been used now does not appear automaticly i have to open my avaliable abilty screen and re-equiop them, again was this mot a past problem that they fixed ? Seems to me that alot of old problems have come back. One can not help but to think are they being shallow and petty, is this all due to our response to the lash back we all gave about the dilithium scam ? I Love this game and uasually have no problem spending money on it but untill this s..t gets fixed no money shall be spent and my fleet members are in agreement with this.

Really all PWE would have to do to rest people worries is just state the facts . Most of us are resonable and would understand s..t happens codeing gets messed up but do you need to always keep us in the dark. The Loyal players want to KNOW what's UP!
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:48 PM.