Prev Previous Post   Next Post Next
Captain
Join Date: Jun 2012
Posts: 543
Hey all.

Can a dev maybe bort test the armitage using the borg set in ISE and tell me if you also get plasma on your ship and more damage than normal. Because i bought the armitage in the sale and use the borg set at the mo and when im in ISE and fighting cubes or the gate i get plasma damage icons and the green plasma effect on my ship even when no plasma torps have hit my ship. (indicating invisible plasma torps hitting me). Also maybe the something wrong with the borg set letting plasma damage get on me easier than say a maco shield or whatever which yeah i know has a 5% more plasma resist but still can you check the plasma damage with this ship and set bort in Infected Elite Space against cubes and the gate please in a real playing environment.

9 times out of 10 i have plasma damage and fires on my ship at the start of ISE but im well enough back and never see a plasma torp ever launch at me or hit me yet i get plasma icons and the fires showing on my ship. And i want to know why this ship and set in particular are really weak and keep getting these damages on my ship compared to ships and sets differently. In any other environment my ship is very strong and is very hard to get damaged like this.

Im a player since open beta so i know how things generally should work and i feel this is bugged somehow. Especially the invisible borg torps or maybe its different invisable weapon these days that deals plasma damage and plasma fires like a plasma torp does who knows. I have a high spec pc i5 3570k gtx 570 gfx card, corsair arctic white 8gb ram asus dg scard etc so not like i have a problem with the visuals or fps or anything.

Compared to my jem bug ship with maco shield and my gurumba with the kdf shield which they both dont seem to get anywhere near the amount of plasma damage or fires on compared to the armatige with the borg shield im just wondering whats wrong and why when fighting cubes or gates (maybe spheres but not sure) i get plasma effects on my armatige every few mins which i never get on the other ships i use.

Edit - Just noticed magic plasma on my bug today so not just happening on borg shield or armitage, tho i do feel that the armitage does get instantly destroyed unlike the bug ship or the gurumba for example.

I still would like it if you bort can test the armitage tho and the borg set to see if theres something causing instant deaths with it in ISE when no plasma torp hits it but something else or it really is inv torps or invisble somit that is doing it.

Last edited by cptskeeteruk; 12-03-2012 at 01:30 PM.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:50 AM.