Career Officer
Join Date: Jun 2012
Posts: 845
# 21
12-11-2012, 09:24 PM
Quote:
Originally Posted by kirksplat View Post
I'm just not sure how I will make missions with that fail safe in preview. Basically, I'll have to use the preview to build sets and then each mission will have weeks of "Yes, this is published, but DO NOT PLAY! Testing in progress."

Meh... it's not like we can actually test combat anyway. But, it will be incredibly frustrating for new authors who have no idea how scaling and mobs work.

Yes, this is the major problem. Also, the really bad thing is it makes it difficult to even run through a mission that has any combat (to test anything besides combat), because the NPC groups disappear and you have to run all around the map tracking them down, if you can even reach them. A lot of times you don't even have a chance to target and use the kill NPC button on all of them before they're gone.

It means we might as well just not even have preview for anything other than viewing sets. I suppose you can just put all the combats in last, but that's really clunky.


Click here for my Foundry tutorial on Creating A Custom Interior Map.
Starfleet Veteran
Join Date: Jun 2012
Posts: 884
# 22
12-12-2012, 08:31 AM
Quote:
Originally Posted by nagorak View Post
Yes, this is the major problem. Also, the really bad thing is it makes it difficult to even run through a mission that has any combat (to test anything besides combat), because the NPC groups disappear and you have to run all around the map tracking them down, if you can even reach them. A lot of times you don't even have a chance to target and use the kill NPC button on all of them before they're gone.

It means we might as well just not even have preview for anything other than viewing sets. I suppose you can just put all the combats in last, but that's really clunky.
This is also a new problem as I have never had this problem while working on previous missions prior to Season 7. I have always used the publish testing as my final check before I release a mission for general play.

I'm sure they are working on it.
If you would like a detailed review of your mission please visit my forum posting "In depth mission reports upon request" for details. Also see Evil 70th's list of missions at "Evil 70th's Missions".
Captain
Join Date: Jun 2012
Posts: 3,054
# 23
12-12-2012, 09:50 AM
Here is what Bajoran Fire Cave is like:

http://youtu.be/1MJIk2BPBNo

Last edited by kirksplat; 12-12-2012 at 09:52 AM.
Ensign
Join Date: Nov 2012
Posts: 20
# 24
12-12-2012, 06:20 PM
Yes, this is happening now; and no, it didn't used to happen.

I wouldn't mind so much, because you could always publish the partial mission just to test it for a little bit, and then withdraw the publish.

Unfortunately, though, as of today, it seems that publishing is once again broken. Everything halts at 50%.
Captain
Join Date: Aug 2012
Posts: 683
# 25
12-13-2012, 06:17 AM
well, it would seem I too have this same problem. I'm using the map used in the episode that you use to be able to get the universal borg console from?

I'm using the map where you fight the boss. And two things keep happening:

1- my away team members dissappear and it shows that they are like 500m away, then they die...?!?


2 - the group of borg that I have placed on that map (a task to kill the enemy), when it comes time to fight them, one by one they dissappear !?!?

Will this mean that when I am finished creating my entire Mission entitled "Long Lost Friend 2" --as you can imagine I've published " 1 ", it was my first creation recently.

This second one I been working on, (the one I am currently having troubles with , as mentioned above), does what I described.

Not in all the maps, just in the last one I mentioned. Though it has acted funny sometimes in other maps.

I too have noticed groups of npcs falling from the sky in every map I place them.

Yeppers. so ,,, any advice? thoughts?
Rihannsu
Join Date: Jun 2012
Posts: 14,488
# 26
12-13-2012, 08:47 AM
Try a publish and see if that fixes it. AFAIK the issue with preview is the lack of pathing data. For some reason NPCs are having their coordinates get reset to 0/0/0. This causes them to disappear at random, sometimes for identifiable reasons, sometimes not....
HAIL HYDRA!

-=-=-=-=-=-=-=-=-=-
I can haz joystick!
MMOs aren't charities. Corporations are supposed to make a profit. It's what they do.
Career Officer
Join Date: Jun 2012
Posts: 298
# 27
12-13-2012, 08:59 AM
I had a similar issue with this on a space map believe it or not. I created a pretty generic space map and when I would load in to test it a Security Officer can be seen outside the ship repeatedly falling as if involved in some sick Q Portal game.

Not sure if that's related or not, but I wouldn't figure that away team members would be outside the ship on a space map.
Career Officer
Join Date: Jun 2012
Posts: 298
# 28
12-13-2012, 09:01 AM
Also I guess on a side note when using the TOS Ship Interior map and the TOS Bridge map the away team doesn't seem to stay with you. I attempted to even to spawn in the Engineering room and they hit a wall and away they would go. Ultimately I would have liked them to spawn in the Turbolift but they either never show up or are stuck behind the walls. Looking at the spawn point radius on the map they should all fit in there, but it's really hard to say with that issue.
Captain
Join Date: Aug 2012
Posts: 683
# 29
12-13-2012, 09:10 AM
Quote:
Originally Posted by markhawkman View Post
Try a publish and see if that fixes it. AFAIK the issue with preview is the lack of pathing data. For some reason NPCs are having their coordinates get reset to 0/0/0. This causes them to disappear at random, sometimes for identifiable reasons, sometimes not....
Good idea. I was thinking about doing that. It's just, I didn't do that yet, cause I don't want people who are, well, easy to say bad things..... to say bad things, because it didn't correct itself after publish....

plus I have a couple more maps to do.

yet if this is not fixed after todays patching update, then I will try that. This one is called "Long Lost Friend 2" the one I'm working on. It's got some comedy in it, and I think a fun idea for a mission.

Course Time travel is involved....

Oh, and , drudgy, that actually is happening to me as well. If I begin from the start of the story, I'll see a green target on the map, and it'll be a security officer! So , not having the correct officers beam down, is also a definit constant so far.

And also, what you said about the TOS ship interior, I used it for my first episode I created a few days ago, it's published and available for people to play now. That one is called "Long Lost Friend."

Well anyways, I chose the spawn point to be in the engineering room, and thankfully everyone beams in good.

But I have had that problem as well.

One of the cool things I've done in the 2nd episode I'm creating, is a klingon ship comes to the rescue of your main fed character in a battle. I did that by using the fed npc group, but choosing a klingon ship for the costume.

anyhow

I hope they fix the issues.
Rihannsu
Join Date: Jun 2012
Posts: 14,488
# 30
12-13-2012, 09:18 AM
Quote:
Originally Posted by drudgy View Post
I had a similar issue with this on a space map believe it or not. I created a pretty generic space map and when I would load in to test it a Security Officer can be seen outside the ship repeatedly falling as if involved in some sick Q Portal game.

Not sure if that's related or not, but I wouldn't figure that away team members would be outside the ship on a space map.
That's an issue with redshirts following a captain in preview mode... for some reason they don't always despawn when you transition from ground to space. If you have real Boffs they work properly(yes, I know, MUCH easier said than done), it's just redshirts that have issues.

The TOS issue sounds like the same bug with Boffs moving to the 0/0/0 point at random.
HAIL HYDRA!

-=-=-=-=-=-=-=-=-=-
I can haz joystick!
MMOs aren't charities. Corporations are supposed to make a profit. It's what they do.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:31 PM.