Ensign
Join Date: Sep 2012
Posts: 29
# 1 Sto on ubuntu ? I need help
12-23-2012, 12:37 PM
I would relly want that sto operates on my ubuntu os
I tried so things with wine and windtricks but i cant seem to win against ubuntu
Im running ubuntu 12.10
Please give me a turotial to get sto on linux

This are things i installed with wine tricks:
D3dx9
Ie7 (ie8 didn't worked at all)
Vrun 2008 and i tried 2010
Flash player
And the corefronts
Career Officer
Join Date: Jun 2012
Posts: 4,629
# 2
12-23-2012, 12:41 PM
If memory serves, the issue is in the .net part of the launcher.

Try launching the client, rather than the launcher.
My name may say "PWE member", but I will never be.
-NEVER Forget the Screwups and ignorance made towards the people who supported the game through 2011
Don't look silly, don't call it "Zen-Store" - Don't waste devs time, Post proper bug-reports
Ensign
Join Date: Sep 2012
Posts: 29
# 3
12-23-2012, 12:53 PM
How do i start the client

And i dont now how but i did start the launcher and start the client
It crashd while loading and i didnt came so far again

And can i use the client when the game isn't patched
Career Officer
Join Date: Jun 2012
Posts: 4,629
# 4
12-23-2012, 01:09 PM
Quote:
Originally Posted by sycrus View Post
How do i start the client

And i dont now how but i did start the launcher and start the client
It crashd while loading and i didnt came so far again

And can i use the client when the game isn't patched
Im just bugtracing right now... I dont use Linux myself, but I have a fair deal of expirience with it.

If we can launch the game without the launcher, we know where to look... then we know where to start.

You need to find the game exe file in your mounts....

Not sure what it would be on linux, but on a Win, it should be "%program files%\Cryptic Studios\Star Trek Online\Live\GameClient.exe" i belive...

You probably have it in your /usr or /bin (or /etc?)
My name may say "PWE member", but I will never be.
-NEVER Forget the Screwups and ignorance made towards the people who supported the game through 2011
Don't look silly, don't call it "Zen-Store" - Don't waste devs time, Post proper bug-reports

Last edited by anazonda; 12-23-2012 at 01:13 PM.
Ensign
Join Date: Sep 2012
Posts: 29
# 5
12-23-2012, 01:18 PM
Quote:
Originally Posted by anazonda View Post
Im just bugtracing right now... I dont use Linux myself, but I have a fair deal of expirience with it.

If we can launch the game without the launcher, we know where to look... then we know where to start.

You need to find the game exe file in your mounts....

Not sure what it would be on linux, but on a Win, it should be "%program files%\Cryptic Studios\Star Trek Online\Live\GameClient.exe" i belive...

You probably have it in your /usr or /bin (or /etc?)
Doesn't the games exe just starts the launcher ?
But i also got a friend with a windows pc i can at least test it with the client

Last edited by sycrus; 12-23-2012 at 01:21 PM.
Career Officer
Join Date: Jun 2012
Posts: 4,629
# 6
12-23-2012, 01:51 PM
Quote:
Originally Posted by sycrus View Post
Doesn't the games exe just starts the launcher ?
But i also got a friend with a windows pc i can at least test it with the client
No... the launcher and the client are seperate enteties... The launcher simply provides patch access/evaluation as well as directed login.

The game client is usually launched through the launcher, but it is not required, if your client is up to date.

But... come to think of it, The launcher IS powered by IE... You might want to investigate if you can sucessfully install IE9 or later?

I will be offline for the next 8'ish hours... sleep is a b*tch, but nessacary.

Try my suggestions, and hope someone else can help you... If not, I will look into this thread tomorrow again...
My name may say "PWE member", but I will never be.
-NEVER Forget the Screwups and ignorance made towards the people who supported the game through 2011
Don't look silly, don't call it "Zen-Store" - Don't waste devs time, Post proper bug-reports
Career Officer
Join Date: Jun 2012
Posts: 4,629
# 7
12-23-2012, 10:28 PM
was skimming through the old forums, and found this:

http://sto-forum.perfectworld.com/sh...buntu+anazonda

Post #2 is mine... Seems it solved the issue back then.
My name may say "PWE member", but I will never be.
-NEVER Forget the Screwups and ignorance made towards the people who supported the game through 2011
Don't look silly, don't call it "Zen-Store" - Don't waste devs time, Post proper bug-reports
Ensign
Join Date: Sep 2012
Posts: 29
# 8
12-24-2012, 12:16 AM
Ok had it alsmost functional i was able to get on the screen with the text cryptic
But it crashed on the next screen : the logo it didnt relly crashed but it just didnt get farder
I dont now how but i cant start the client not in the launcher and not by the gameclient.exe
Career Officer
Join Date: Jun 2012
Posts: 4,629
# 9
12-24-2012, 12:39 AM
Ok, so that issue is removed from the checklist...

There is a file... MS*somethingsomething*.dll that the launcher initiates... It's apprearently not nessacary on the windows, but it might just be in Ubuntu...

Ill see what I can figure out
My name may say "PWE member", but I will never be.
-NEVER Forget the Screwups and ignorance made towards the people who supported the game through 2011
Don't look silly, don't call it "Zen-Store" - Don't waste devs time, Post proper bug-reports
Ensign
Join Date: Sep 2012
Posts: 29
# 10
12-24-2012, 12:57 AM
Quote:
Originally Posted by anazonda View Post
Ok, so that issue is removed from the checklist...

There is a file... MS*somethingsomething*.dll that the launcher initiates... It's apprearently not nessacary on the windows, but it might just be in Ubuntu...

Ill see what I can figure out
How do you get it
But the launcher works or is it for the client

Last edited by sycrus; 12-24-2012 at 02:21 AM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:24 AM.