Prev Previous Post   Next Post Next
Ensign
Join Date: Jun 2012
Posts: 18
Well, this is far from the first issue I've had with Perfect World's support and last time I was censored here. Hopefully someone can actually bother to deal with my issue rather than just shut me down and drive me out again.

So, we have the ultimate game card promo going on. I have a $25 card with no option to redeem a $25 card via Perfect World's site. Attempts to get into support lead simply to an error stating,

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept
cookies.

For the record: I allowed cookies on Perfect World's site. The issue has persisted, so I used IE to get into the support website and found Firefox was right! Any and all attempts to get into the "support" or "contact us" areas of Perfect World's site result in a never ending login loop that consistently demands my login credentials and then loops back right to demanding my login credentials again.

Does Perfect World not care about their customers at all? The first time I needed assistance I was shut down and censored. Now I'm just getting a never ending run around loop.
[SIGPIC][/SIGPIC]

Last edited by zeroalexandra; 01-15-2013 at 08:48 PM.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:44 PM.