Survivor of Remus
Join Date: Oct 2012
Posts: 347
While lag can be caused by any number of things that Cryptic has no control over,they cannot deny the fact that when most,if not all,of the players are experiencing frequent disconnects on map transfers,server not responding,extreme UI lag with activation of skills/weapons and using the reputation/fleet tabs,PvE and PvP queues that fail to launch or leaving team members behind....that there is something seriously going wrong on their end.

And yet,when the devs are asked politely in the REDALERT channel when these lag issues will be dealt with....we are met with silence and the ignore button.Why? Is this something the devs can't fix?They have no control over their own game engine? Incompetence? Or have they filed it under "working as intended" with the rest they can't be bothered to fix?

How can we play and enjoy a game when it is fighting us at every turn....


If you are as fed up with the constant lag as I am,post in this thread and let them know enough is enough.
Starfleet Veteran
Join Date: Jun 2012
Posts: 3,322
# 2
01-16-2013, 11:50 AM
Isn't season 8 supposed to rework the UI to address such problems?
---------------------------------------------------------------------------------
Promote what you love, instead of bashing what you hate.
https://www.youtube.com/watch?featur...lM_skuv4#t=584
Lieutenant
Join Date: Jul 2012
Posts: 39
# 3
01-16-2013, 11:54 AM
I don't know if this will help or not but I only see the UI lag after re-spawning during STFs. As for the disconnects I only seem to have them during the Winter Event, New Romulus, and occasionally during Foundry missions.
Survivor of Remus
Join Date: Oct 2012
Posts: 347
# 4
01-16-2013, 02:16 PM
I've done a fair bit of ground PvP....death by failing hypo/skill is common. This is the thing I don't get,with Season 4 most of the UI lag was gone,it was beautiful....now a paraplegic crawling uphill moves faster,it's ridiculous...
Captain
Join Date: Jun 2012
Posts: 1,360
# 5
01-16-2013, 02:31 PM
Some of that UI lag is deliberate. I can click those buttons faster than the bridge officer abilities will activate. The stated reason for this is overblown fear of the the dreaded "I win button" boogeyman showing up in someone's keybinds. That built-in delay is why I don't bother with keybinds, incidentally.

I personally don't see it being some overwhelming game-breaker to be able to activate all attack buffs, power buffs, heal buffs, or speed buffs at the same time. That's just silly.
Survivor of Remus
Join Date: Oct 2012
Posts: 347
# 6
01-16-2013, 04:31 PM
Quote:
Originally Posted by hanover2 View Post
Some of that UI lag is deliberate. I can click those buttons faster than the bridge officer abilities will activate. The stated reason for this is overblown fear of the the dreaded "I win button" boogeyman showing up in someone's keybinds. That built-in delay is why I don't bother with keybinds, incidentally.

I personally don't see it being some overwhelming game-breaker to be able to activate all attack buffs, power buffs, heal buffs, or speed buffs at the same time. That's just silly.
But come on....having to hit that one skill that will save your life 7 or 8 times before it activates just as you die....how is that good game design?
Ensign
Join Date: Jan 2013
Posts: 14
# 7
01-17-2013, 03:54 AM
you could always put in a ticket, wait a week and get a response that it's something new and unknown and close your ticket without helping you.
Rihannsu
Join Date: Jun 2012
Posts: 3,945
# 8
01-17-2013, 05:49 AM
Quote:
Originally Posted by carcharodon1975 View Post
But come on....having to hit that one skill that will save your life 7 or 8 times before it activates just as you die....how is that good game design?
that is clearly not by design. the powers should activate smoothly.

i personally have not experienced any of the issues you describe recently. sure there are the occasional lag spike or the odd disconnect, any MMO will have that from time to time, but what you describe is neither by design or something ive noticed. i see some UI lag occasionally with the Doff screen but thats about it.

Are you sure all your drivers are up to date? that you dont have a firewall blocking your connection, some kind of foreign software slowing your upload speeds? problems with your service provider.

If people were having to hit powers 7 or 8 times i think the forums would be ablaze with threads. i really dont think this is everybody, or even most people. it sounds like a smaller group of people are affected.

House of Cards - Lvl 46 Fed mission
Career Officer
Join Date: Jun 2012
Posts: 3,400
# 9
01-17-2013, 06:52 AM
Quote:
Originally Posted by captainrevo1 View Post
i personally have not experienced any of the issues you describe recently. sure there are the occasional lag spike or the odd disconnect, any MMO will have that from time to time, but what you describe is neither by design or something ive noticed. i see some UI lag occasionally with the Doff screen but thats about it.

Are you sure all your drivers are up to date? that you dont have a firewall blocking your connection, some kind of foreign software slowing your upload speeds? problems with your service provider.
I have experienced this UI lag repeatedly and consistently, and it seems to be getting worst.

I don't have this issue playing other MMOs, and everything is up to date on my end.

Most of my friends also experience this dreaded UI lag, it's worse on ground but at some point between S5/6 it seems to have slowly crept into and gotten worse in space as well.

Captain
Join Date: Jul 2012
Posts: 2,265
# 10
01-21-2013, 01:06 PM
Agreed. I've gotten so many different types of error messages, I might as well start a Catalog.

However, CS's response was to uninstall Panda Media Booster. It actually did help with the lag and booting issues. Now, only on my KDF toon do I get a disconnect (boot) problem., and occasional lag issues on First City.

stardestroyer001, VA Explorers Fury | Retired STO Player
My Useful List of STO Forum Threads, Ship Builds & More! | My Forum Gripes
PvP: PvP Boot Camp, the best newbie oriented training initiative in STO!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:09 PM.