Ensign
Join Date: Sep 2012
Posts: 21
Since the latest patch and the previous many many patches. I always seem to hit this bug, no connection to patch server. And the launcher times out, I can't use the game client, which is even more annoying. So, does anyone have the latest launcher again, please?
Lieutenant
Join Date: Jul 2012
Posts: 80
# 752
01-24-2013, 11:57 AM
I have the same problem! Everytime I try to open the launcher, it doesn't work!
P2W means Play To Win

Archimede - Leader and Founder of "Raiders of Starfleet"
...and 21 other characters!
Ensign
Join Date: Jan 2013
Posts: 3
# 753
01-24-2013, 12:06 PM
I've had the same issue since the servers went back up, I had the launcher pulled up and the patch was downloaded but had to close it. From that point forward I've been unable to get it back up. I can't even get the C-store pulled up.
Career Officer
Join Date: Jun 2012
Posts: 1,448
# 754
01-24-2013, 12:08 PM
Have you all tried to replace your launcher as per this stickied topic: http://sto-forum.perfectworld.com/sh...d.php?t=505501

While the OP says Jan 4th, Branflakes said the link in the OP delivers the latest launcher.
nynik | Join Date: Dec 2009
<Dev> Oaks@dstahl: *checks for CBS listening devices in the office*

Last edited by nynik; 01-24-2013 at 12:10 PM.
Starfleet Veteran
Join Date: Jun 2012
Posts: 281
# 755
01-24-2013, 12:09 PM
How can you play the game, without the launcher?
Ensign
Join Date: Sep 2012
Posts: 21
# 756
01-24-2013, 12:10 PM
Yep, just found it here after googling it http://files.startrekonline.com/laun...k%20Online.exe
Career Officer
Join Date: Aug 2012
Posts: 30
# 757
01-24-2013, 12:21 PM
That fixed it for me, thanks.
Lt. Commander
Join Date: Jun 2012
Posts: 186
# 758
01-24-2013, 12:28 PM
Woohoo Star Trek Offline!
Captain
Join Date: Jun 2012
Posts: 622
# 759
01-24-2013, 12:32 PM
Considering the launcher attempts to patch itself every time you desire to play, one would think the launcher is always the latest version. But it's Cryptic. This should be expected.
All cloaks should be canon.
Ensign
Join Date: Jan 2013
Posts: 3
# 760
01-24-2013, 12:39 PM
It somehow started up again? I downloaded the updated launcher a few times with no success and now out of nowhere everything is golden? Weird.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:01 AM.